Jump to content


XVM Config

XVM Config

This topic has been archived. This means that you cannot reply to this topic.
125 replies to this topic

EngIand #1 Posted 12 February 2013 - 10:56 PM

    Lance-corporal

  • Beta Tester
  • 0 battles
  • 28
  • Member since:
    11-01-2010
ENGiAND's - XVM config - XVM 3.5.0test1 ( Make sure you use the latest XVM-Stat, 1.3.0+ )

Xvm.xvmconf is setup to show individual tank stats. Win% (In Tank) | WN# Efficiency | Games Played (In Tank)
Each is set to display for their own rating, both on the scoreboard / loading screen and above the tanks in ALT View
All colours used for individual values are Original XVM Editor / XVM defaults.
( Minor change to Squad-mate damage colour only )
(Not counting Minimap)

Available through The XVM Community and Curse
XVM Community   /   Archive

Curse

Posted Image

Ive also Edited the OTM information that shows above the tank / player in game
Damage Taken includes the % of health each hit was worth. ( I like this alot ) ( You saw it HERE first ! )
( Boom ! ) Ammo rack damage text has been replaced with ( Fucked ! )

ALT - Now shows 3 lines of information
TANK STATS
OVERALL STATS -   WN# Scale Rating
WN7 EFFICIENCY

(XVM Editor View)
Posted Image

ALT - Now shows 3 lines of information
TANK STATS
OVERALL STATS -   WN# Scale Rating
WN7 EFFICIENCY

(Real World View)
Posted Image

NEW in 3.1.1
HIT LOG
Posted Image

XVM Community Sixthsense Icon
Posted Image

Sixthsense.png needs to be installed to : \World_of_Tanks\res_mods\icons

NEW IN 3.3.2
Minimap
Posted Image

The "xvm.tff" font file needs to be installed in order for Icons on Minimap to display correclty.
XVM.TFF
Thanks go to Andrey_Hard for Minimap Icons.

Enemy Tracking / Colouring / Circles
50M RED
445M DARK BLUE
600M LIGHT BLUE

Squad Mates are detailed by their name ( Limited to 6 characters )

Edited by EngIand, 15 March 2013 - 11:37 AM.


KoniecJestBliski #2 Posted 13 February 2013 - 11:07 AM

    Lance-corporal

  • Player
  • 0 battles
  • 87
  • Member since:
    08-03-2011
Great config for minimap, shows last known position of enemy who isn't spotted anymore, but I'm not sure if its legal (feels little like cheating).

:Smile_sceptic:

Also, on some maps (hills, cliff) range circles and direction lines are not displayed on minimap.  On other maps like lakeville and erlenberg everything works fine. WTF?

Edited by KoniecJestBliski, 13 February 2013 - 01:03 PM.


EngIand #3 Posted 13 February 2013 - 09:52 PM

    Lance-corporal

  • Beta Tester
  • 0 battles
  • 28
  • Member since:
    11-01-2010

View PostKoniecJestBliski, on 13 February 2013 - 11:07 AM, said:

Great config for minimap, shows last known position of enemy who isn't spotted anymore, but I'm not sure if its legal (feels little like cheating).

:Smile_sceptic:

Also, on some maps (hills, cliff) range circles and direction lines are not displayed on minimap.  On other maps like lakeville and erlenberg everything works fine. WTF?

Minimap at time of this reply is still in testing, has been for some time. WG have not stated that it has any problems with this Minimap functionality.

As the Minimap is still in testing just keep upto date with the official releases of XVM from their offical download page http://code.google.c.../downloads/list

Zegrze #4 Posted 16 February 2013 - 12:13 AM

    Sergeant

  • Player
  • 0 battles
  • 376
  • Member since:
    04-10-2011
I have been using your config with very minor alterations (to clan icons mainly) for some time now, big TY for a very good informative config. +1

EngIand #5 Posted 16 February 2013 - 12:44 AM

    Lance-corporal

  • Beta Tester
  • 0 battles
  • 28
  • Member since:
    11-01-2010

View PostZegrze, on 16 February 2013 - 12:13 AM, said:

I have been using your config with very minor alterations (to clan icons mainly) for some time now, big TY for a very good informative config. +1

Thank you. Your Welcome. And thanks for the +1

TonyWwW #6 Posted 16 February 2013 - 02:40 AM

    Junior Sergeant

  • Player
  • 0 battles
  • 124
  • Member since:
    04-05-2011
I have installed this - awesome work many Thanks

CuP1D #7 Posted 16 February 2013 - 03:04 AM

    First Sergeant

  • Player
  • 0 battles
  • 2,126
  • Member since:
    11-03-2011
Yep, i have been using this - very good mate, keep it up

mreddd #8 Posted 17 February 2013 - 12:27 PM

    Lance-corporal

  • Player
  • 0 battles
  • 12
  • Member since:
    02-04-2013
I must say i like your mod i have just 1 small problem, the icons off the other team are mirrored.
Hope you can help me wih this.

Arttu #9 Posted 17 February 2013 - 05:07 PM

    Junior Sergeant

  • Player
  • 0 battles
  • 208
  • Member since:
    02-28-2011

View Postmreddd, on 17 February 2013 - 12:27 PM, said:

I must say i like your mod i have just 1 small problem, the icons off the other team are mirrored.
Hope you can help me wih this.

Open (in Notepad or similar) file XVM.xvmconf (in res_mods\0.8.3\gui\flash).
Find: "mirroredVehicleIcons": true, and change "true" to "false".
Save file - that's it.

Quoted from someone else in another topic. :)

mreddd #10 Posted 17 February 2013 - 05:36 PM

    Lance-corporal

  • Player
  • 0 battles
  • 12
  • Member since:
    02-04-2013
Thank you very much that solved my problem.

Zegrze #11 Posted 18 February 2013 - 02:04 PM

    Sergeant

  • Player
  • 0 battles
  • 376
  • Member since:
    04-10-2011
I noticed on the minimap that quite a few non-SPG units are using the SPG square symbol.

It is not a huge problem as the vehicles are still named but it is a niggle.

I assume this is a problem of XVM itself rather than your config?

EDIT

Quote

Reported by emh...@gmail.com, Feb 13 (4 days ago)
The new minimap displays a wrong class icon for enemy TDs (shows SPG icon).
See attached screenshot
Observed with 3.3.2-test7
Feb 14 (4 days ago) #2 emh...@gmail.com
Disregard this issue - it was caused by a seemingly incompatible minimap.pyc from a previous different minimap mod that wasn't removed properly.

Ah found this on the XVM issues section of their forums. I dont know if anyone else is having this issue but I am pretty sure the only other map mod I was using was Locastan's HD mod. If anyone else uses this mod and also has similar icon issues please let me know.

Edited by Zegrze, 18 February 2013 - 02:12 PM.


WolfieBaby #12 Posted 18 February 2013 - 03:35 PM

    Lance-corporal

  • Player
  • 0 battles
  • 36
  • Member since:
    04-16-2012
Hi Zegrze,

Yes I noticed this also, and im using Locastan's HD minimap mod - so it is interesting you mention this, I will try uninstalling the HD minimap MOD and see how that affects it..

Wolf..

EngIand #13 Posted 18 February 2013 - 09:15 PM

    Lance-corporal

  • Beta Tester
  • 0 battles
  • 28
  • Member since:
    11-01-2010

View PostZegrze, on 18 February 2013 - 02:04 PM, said:

I noticed on the minimap that quite a few non-SPG units are using the SPG square symbol.

It is not a huge problem as the vehicles are still named but it is a niggle.

I assume this is a problem of XVM itself rather than your config?


Can you please post a screenshot of what it is your talking about, i think i know but its not something im seeing, The way ive got the config setup, there was at 1 point a time when i was going to just use some default Font symbols for the tanks but then Andrey Hard uploaded a new XVM.tff font file and i deceided to include those as they are much better for the minimap as icons to just.

Like i said, if you can post a screenshot and also make sure youve installed the XVM.tff font file to make sure the minimap icons display correctly.

sander454 #14 Posted 18 February 2013 - 09:59 PM

    Lance-corporal

  • Player
  • 0 battles
  • 47
  • Member since:
    01-29-2011
Hi England,
Firstly grats for such a great mod.
Secondly - would it be possible for you to create xvm config file that shows both global and particular stats for a player? I've seen one here: http://drongo-lab.ru/archives/48905 and I was wondering if you could create something like that and post here?

Zegrze #15 Posted 18 February 2013 - 10:02 PM

    Sergeant

  • Player
  • 0 battles
  • 376
  • Member since:
    04-10-2011
Here are some screen shots as requested.

I installed the font by clicking on the font installation icon that came with the mod after unpacking. I received a font installation popup screen as font was installed, although where it was installed I have no idea.

There are two issues actually: the first being the seemingly incorrect assignation of icons and the second being a text anomaly where  some spotted vehicles no longer display the normal spotted but gone icon and name but present the display '(Vehicle Type) Nameoftank' on the minimap.

I do like my Locastans HD minimaps, they are jolly nice to use and would be a pity to have to revert to the standard one to get this jolly nice feature of XVM working correctly.

In this first shot we can see friendly Patton, E50M, 121 and JagdPz E100 displaying the square icon for SPGs on the minimap.

Spoiler                     

Here we have an E50M showing the same issue. We also have a text anomaly '(Vehicle Class) AMX 50Foch' just south of centre of minimap.

Spoiler                     

This time, icons are correct however we have another example of the text anomaly '(Vehicle Class) JgPanther' starting at B2 location.

Spoiler                     

I much appreciate any considered thought about this issue from you tech whizzes. :)

Edited by Zegrze, 18 February 2013 - 10:06 PM.


EngIand #16 Posted 18 February 2013 - 10:34 PM

    Lance-corporal

  • Beta Tester
  • 0 battles
  • 28
  • Member since:
    11-01-2010
Your first and second screenshots are both displaying Icons that i have not included in my setup. There are other icon fonts for XVM that are available, the font file i included does not contain the TD icons you are displaying on the minimap and the only way i know of for them to display is if you have installed other icon font files and then edited the xvm.xvmconf and told it to display them.

As for the vehicle class issue, the {vehicle} macro was changed from {vehicle} to {vehicle-class} in the most recent changes to the .swf files. I think you need to update to the most recent release of the test XVM download, ( Currently test8 ) and that should resolve this issue.

I would sugest that you do a full clean install. grab my conf file fresh and do a full re install of the .swf files. Also might want to remove the HD minimap and, do your clean install, make sure everything is working corretly befor trying further mods to the minimap.

KoniecJestBliski #17 Posted 18 February 2013 - 10:40 PM

    Lance-corporal

  • Player
  • 0 battles
  • 87
  • Member since:
    08-03-2011

View PostZegrze, on 18 February 2013 - 10:02 PM, said:

There are two issues actually: the first being the seemingly incorrect assignation of icons and the second being a text anomaly where  some spotted vehicles no longer display the normal spotted but gone icon and name but present the display '(Vehicle Type) Nameoftank' on the minimap.
I much appreciate any considered thought about this issue from you tech whizzes. :)
@Zegrze
Sounds like the same problem I had:
http://forum.worldof...18#entry4035618

Zegrze #18 Posted 19 February 2013 - 02:08 AM

    Sergeant

  • Player
  • 0 battles
  • 376
  • Member since:
    04-10-2011
Thanks for the replies guys.

England, when you say full clean install do you mean deleting the full game as it is, redownloading and then reinstalling or simply deleting all in my res mods folder? The reason I ask is that none of the mods I have, to the best of my knowledge, have any placement outside of the res mods folder.

My XVM version used during these screenshots was 3.3.2_test8 with XVM stat 1.2.3

To the best of my knowledge I have never knowingly installed any other font sets for icons or otherwise since getting this PC a year ago. Maybe some mod has done this without my knowledge, I will have to check this. I was wondering why, prior to installing your config why some SPGs displayed double/triple bar square or solid square, I could never quite figure it out why.

Mods I have installed at present are:

ReCos vertical tech tree (1920)
Cmsgv2+stats_locastan
COH Brit voice detection
Credit + XP buttons
Custom Serverside CH8.2
DmgPnl_autocentre_83
your XVM config 3.3.2-test6
GnomeFathers engines V0.382
Ingame Clock 8.3
J1mB0s Crosshair Mod v1.21 and English set
kiskami-paintball-mod-080
locastans enhanced Minimap_2ndGen_8.3
NikodemskyContourModv221_083hash2
sauron8.3+sound
Train_Wagon_Collision_Mode_Visibility

Mods I am unsure about whether actually installed or fully removed if installed are:

kaeptns contour
HiResFlags0.2
Minimap_sonar
Radial Menu_enh_83

I do not use any mod installer and do all my installs manually, which I must admit sometimes albeit rarely leaves me wondering which files to install first or overwrite on the odd occasions there are conflicts.

Quote

As for the vehicle class issue, the {vehicle} macro was changed from {vehicle} to {vehicle-class} in the most recent changes to the .swf files. I think you need to update to the most recent release of the test XVM download, ( Currently test8 ) and that should resolve this issue.

When I check the current config file of yours I am using at the moment, using the swf editor online, all references I can find to vehicles in loading, tab and players panel are still {vehicle} and not {vehicle-class}. Maybe I have the wrong end of the stick here but I am not sure which should be visible in the editor for all to be correct and up to date.

Edited by Zegrze, 19 February 2013 - 02:26 AM.


EngIand #19 Posted 19 February 2013 - 02:09 AM

    Lance-corporal

  • Beta Tester
  • 0 battles
  • 28
  • Member since:
    11-01-2010

View PostZegrze, on 19 February 2013 - 02:08 AM, said:

Thanks for the replies guys.

England, when you say full clean install do you mean deleting the full game as it is, redownloading and then reinstalling or simply deleting all in my res mods folder? The reason I ask is that none of the mods I have, to the best of my knowledge, have any placement outside of the res mods folder.



I meant doing a full mod re-install. delete res mods and start again

Edited by EngIand, 19 February 2013 - 02:10 AM.


Zegrze #20 Posted 19 February 2013 - 02:59 PM

    Sergeant

  • Player
  • 0 battles
  • 376
  • Member since:
    04-10-2011
This I will do upon my return from work this evening, I will try to make a list of the mods which share same file type as XVM does and which files they are.