Jump to content


Your System Specs?


  • This topic is locked This topic is locked
79 replies to this topic

bomasterflexwinkle #21 Posted 22 August 2010 - 12:53 AM

    Private

  • Beta Tester
  • 3198 battles
  • 36
  • Member since:
    07-19-2010
E8500 @4.8ghz cpu
P5q pro turbo mobo
ocz flex II ram
2 ati 4890's in xfire running at 1.2ghz core and 1.4ghz ram

custom built case and all watercooled

all benchmark speeds not 24/7 but it is 48hrs stable under ibt at those speeds

tenshi_strife #22 Posted 22 August 2010 - 02:12 AM

    Corporal

  • Beta Tester
  • 0 battles
  • 160
  • Member since:
    07-28-2010
Asus Republic of gamers laptop, it was a gift and it runs pretty good so I likes it.

OS: Windows 7 64bit
CPU:Intel Core 2 Duo @2.00GHz
GPU: NVIDEA GeForce GTX 260M
Ram: 4gigs
HD: 286GB

it runs WOT at high setting with no lag, well frames lag :P

Rasmus675 #23 Posted 22 August 2010 - 10:00 AM

    Private

  • Beta Tester
  • 2859 battles
  • 24
  • [VKG-] VKG-
  • Member since:
    07-14-2010
i5-750 @ 2.66 GHz.
4 GB ram from Crucial.
750GB WD black HDD.
XFX HD5850 Black Edition.
MSI CD-53 mobo
Antec Nine Hundred case.

Runs WoT on max with 120-150 fps. :3
( That is 1920x1080, 8x AA, highest detail settings. )

Lappietoppie
i3-350
HD5650 M
4 GB ram
Can't remember HDD size
15.5"

Runs WoT awesomely.

zxmadkiller #24 Posted 10 September 2010 - 08:16 AM

    Private

  • Beta Tester
  • 0 battles
  • 1
  • Member since:
    09-10-2010
HP computer


CPU:amd phenom II x4 processor witch is 2.8 ghz!
RAM: 8gb
OS: windows 7 home premium 64bit
video card: nvidia geforce 9100.
hard drive: 1 terabyte
display: AOC 2236

i am downloading world of tanks and hopfuly it will run!

PvtMalo_ #25 Posted 10 September 2010 - 11:55 AM

    Staff Sergeant

  • Special Beta Tester
  • 58 battles
  • 340
  • [MOP] MOP
  • Member since:
    02-17-2010
niiice

3cxO #26 Posted 10 September 2010 - 03:32 PM

    Lance-corporal

  • Beta Tester
  • 0 battles
  • 79
  • Member since:
    07-17-2010
CPU: Core i7 920 @ 2.67ghz
GPU: 2xGTX 275
RAM: 6gb DDR3
HDD: 2TB (2x1tb raid0)
OS: Windows 7 ultimate x64


My lil' 1y and a half pony.

Deegee #27 Posted 10 September 2010 - 04:01 PM

    Private

  • Beta Tester
  • 263 battles
  • 12
  • Member since:
    09-01-2010
The system my girlfriend 'lovingly' called "Darth Vader"...

CPU : AMD Phenom II x4 945 3.0GHz
RAM : 2x2GB Corsair XMS3
Motherboard : Gigabyte GA-870A-UD3
HDD capacity : 1.2TB
Case : Coolermaster HAF922 (window version)
Monitor : Acer P225HQ (desktop res: 1920x1080)
Video card : XFX 1GB XXX Radeon HD 5770
PSU : Point (generic?) 850W
Mouse : Gigabyte GM-M8000

No lighting... yet. ;)

Edit : Updating video card details.

slaiyen #28 Posted 10 September 2010 - 05:21 PM

    Private

  • Beta Tester
  • 0 battles
  • 0
  • Member since:
    07-17-2010
meh, not the greatest but it works

CPU: AMD Athlon II X4 630 2.8 GHz
Mobo: ASUS M4A785-M
RAM: 4 GB DDR2-667
HDD: 2x 160 GB
GPU: ATI Radeon HD 4650 512 MB
OS: Windows 7 Home Premium

SirDoombox #29 Posted 10 September 2010 - 06:19 PM

    Corporal

  • Beta Tester
  • 2374 battles
  • 143
  • Member since:
    07-30-2010
Makes my computer feel a bit incapable up against some of the ones posted here, but I'm not made of money :P

OS - Windows 7 Home Premium 64bit.
Processor - Intel Pentium 4 dual-core E6600 @ 3.06GhZ
RAM - 4 gigs DDR3
Motherboard - Biostar
GPU - ATI HD4850 1gigs with overclocks and special cooling.
HDD - 320gig 7200RPM + 1x 1TB 7200RPM

Not amazing but it's quite nippy and it can multi-task like nothing I've seen before.

DarknessWarrior #30 Posted 10 September 2010 - 10:10 PM

    Private

  • Beta Tester
  • 2196 battles
  • 44
  • Member since:
    08-07-2010
ASUS G51J 3D here

CPU: i7 720QM @ 1.6~2.8 GHz
GPU: GeForce GTX 260M 1GB VRAM GDDR3
RAM: 4GB DDR3 @ 1066 MHz
HDD: 640GB (320 + 320) + 1TB External HDD
OS: W7 Home Premium
Mouse: ASUS RoG VooDoo 3200 DPI
Display: 120Hz 1366*768 3D Display  :Smile-playing:

Boike #31 Posted 07 October 2010 - 09:57 AM

    Private

  • Beta Tester
  • 4039 battles
  • 2
  • [-SWE-] -SWE-
  • Member since:
    08-24-2010
MB:  Asus M4N78-AM
CPU: AMD Athlon 7750 X2 BE (OC) 3.6Ghz
GPU: ATI Radeon HD 5770 1GB (OC)
RAM: DDR 4GB 333Mhz
HDD: 500GB
OS:  Windows XP x86

Old as hell but works fine :D Just upgraded Graphics. Ram is on its way.

flaskis #32 Posted 07 October 2010 - 10:13 AM

    Lance-corporal

  • Beta Tester
  • 1322 battles
  • 65
  • Member since:
    07-11-2010
Motherboard: Asus P6T Deluxe V2
CPU: Intel Core i7 930 @ 3,1 Ghz
RAM: 6 GB DDR3 @ 1,6 GHz
GPU: Ati Radeon 5870 1 GB
HDD: Intel X25-M SSD disc (plus 2x 2TB discs) :3
OS: Windows 7 x64

WoT runs like a charm at 1920x1200 resolution, except that my fps drops to 2-3 whenever there is smoke covering a part of the screen >_>

Buzz43 #33 Posted 07 October 2010 - 11:57 AM

    Private

  • Beta Tester
  • 0 battles
  • 3
  • Member since:
    07-25-2010
Here is mine,

AMD X965 X4 black Edition 3.44Ghz
8GB DDR3 1600Mhz
GTX 260 x2 (SLI)
Win7 Pro 64
1.5 TB HD

JocaTrica #34 Posted 07 October 2010 - 10:01 PM

    Corporal

  • Beta Tester
  • 23 battles
  • 114
  • Member since:
    07-24-2010
E5200 overclocked @3.3 Ghz
MB Asus P5Q SE
2 GB DDR2 Kingston @850 Mhz (slightly overclocked)
320 GB HDD
9800 GT/512 MB (default settings)
22" @1680x1050
Win XP SP3

... works fine for all the games I'm playing, on mid to high gfx settings. Still have 'untouched' graphic card to overclock and also some reserve regarding CPU and RAM memory frequences (should get another 2 MB module one of these days, though).

DD_Zooly #35 Posted 07 October 2010 - 10:15 PM

    Warrant Officer

  • Beta Tester
  • 11842 battles
  • 641
  • Member since:
    07-30-2010
Phenom II X4 965 Black Edition @ 3.4 GHz
4GB Dual channel memory (DDR2)
GTX 460 768MB
Win 7 64

Crap_Shoot #36 Posted 08 October 2010 - 01:05 AM

    Lance-corporal

  • Beta Tester
  • 0 battles
  • 55
  • Member since:
    08-17-2010
Windows 7 Ultimate 64-bit
Intel Core2 Quad, 2.4GHz
Nvidia GeForce 8600GT
4GB RAM
HDD: (1) 500GB, (1) 1TB

Eegie7411 #37 Posted 19 October 2010 - 01:16 PM

    Lance-corporal

  • Beta Tester
  • 19274 battles
  • 69
  • Member since:
    10-15-2010
AMD Athlon 2800+
1,5GB DDDR 333
500GB HDD
Geforce 7600GT
19" Samsung lcd at 1440x900
Windows Xp

Runs the game on low settings

Looking for a pc with a Graphics card that will run the game on Full HD to play on my plasma.

Anybody have an idea what card would be fast enough without breaking the bank?   <_<

Lert #38 Posted 19 October 2010 - 04:39 PM

    Private

  • Beta Tester
  • 0 battles
  • 41
  • Member since:
    09-02-2010
AMD X2 5600+, 2.9 ghz
4x 1024mb DDR2 800
2x 512 gb 7200 rpm
Radeon HD4850, 512 mb
BenQ 22" 1920x1080

khubla #39 Posted 19 October 2010 - 07:05 PM

    Private

  • Beta Tester
  • 12542 battles
  • 25
  • [BULL] BULL
  • Member since:
    07-10-2010
Got myself a new pc in august from overclockers.co.uk .Runs all games on max settings/shadows etc and handles everything i throw at it.Had the aircooled version but it was damaged when i got it,had to wait on replacement and they sent this  B)

System Specification
- Case: Antec 300 Case with ATI Red case fans.
- Power Supply: Corsair Extreme 600W
- CPU: Intel Core i3 530 2.93GHz Clarkdale overclocked to 4.20GHz
- Motherboard: Gigabyte H55M-UDH2 Intel H55 (Socket 1156) PCI-Express DDR3 Motherboard
- RAM: Corsair XMS3 4GB (2x2GB) DDR3 PC3-12800C9 1600MHz Dual Channel Kit
- Hard Drive: Seagate Barracuda 7200.12 500GB SATA-II 16MB Cache
- Graphics Card: ATI DX11 Compatible Graphics Cards
- Sound: Realtek 7.1 Channel Sound (On-Board)
- Optical Drive: LG DVD+/-RW SATA Drive
- GPU: XFX hd ati 5880 1024mb ddr5

Watercooling
- CPU block: EK Supreme LT Nickel Plexi
- Reservoir and Pump: XSPC 200 Bay Reservoir & Pump - Clear
- Radiator: Hardware Labs Black Ice Stealth GT 120.1
- Fittings: EK High Flow Barbs - Nickel
- Tubing: Masterkleer 7/16" Tubing Red
- Fluid: Fluid XP+ Extreme Red Flame

-teamed up with a 24" monitor,razer habu mouse,logitech g15 keyboard and an old but awesome cambridge soundworks surround sound system.

BCTiger #40 Posted 19 October 2010 - 11:19 PM

    Lance-corporal

  • Beta Tester
  • 0 battles
  • 54
  • Member since:
    06-23-2010
rest of specs to me don't really matter besides:

Graphics: Nvidia 6100 SE intergrated graphics
Memory:1 GB original added 2 more GB
HDD:160 GB

Buying a new comp in about month, in the mean time i'm hoping this thing doesn't die (basicly almost got the HDD over worked so much it would of burnt or whatever if I didn't take it into a comp specialist) I think I have the worst one atm till I get the new one :P

Edit: Heh my 69th post :P




1 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users