Jump to content


mark of excellence bugged?

mark of excellence

  • This topic is locked This topic is locked
3 replies to this topic

Nuk3dFrog #1 Posted 16 July 2014 - 10:19 AM

    Private

  • Player
  • 43482 battles
  • 40
  • Member since:
    01-01-2013
well i have been playing my FV304 with great joy - and have done a fair amount of dmg over +500 battles, my total avg dmg keep rising atm +840 dmg each battle (yes ALL battles) but for a month my 'mark of excellence' stil at 'your better than 64,84% than other players'  - how kan that be when my total avg keep rising and rising. bug or ?

guest273 #2 Posted 16 July 2014 - 10:29 AM

    Captain

  • Player
  • 35394 battles
  • 2,261
  • [DAILY] DAILY
  • Member since:
    05-31-2012
Other players also rise their avg damage.

Nuk3dFrog #3 Posted 16 July 2014 - 10:38 AM

    Private

  • Player
  • 43482 battles
  • 40
  • Member since:
    01-01-2013

View Postguest273, on 16 July 2014 - 10:29 AM, said:

Other players also rise their avg damage.


no1 decending??? ;)



guest273 #4 Posted 16 July 2014 - 10:40 AM

    Captain

  • Player
  • 35394 battles
  • 2,261
  • [DAILY] DAILY
  • Member since:
    05-31-2012

View PostSkraldeSpanden, on 16 July 2014 - 10:38 AM, said:


no1 decending??? ;)

If I see that I am descending on a tank - losing 3 times in a row I just stop playing it for a couple of days...

Maybe the marks just need a week to update or something?







Also tagged with mark of excellence

1 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users