Jump to content


[0.9.6] Tweaked engine_config.xml to fix micro-freezes

tweak fix micro freezes

  • Please log in to reply
31 replies to this topic

Kierrok #1 Posted 26 December 2014 - 10:20 PM

    Staff Sergeant

  • Player
  • 11523 battles
  • 468
  • Member since:
    03-31-2013

Description:
The aim of this tweak is to eradicate the battle micro freezes caused by textures/sounds/effects/etc on the fly load. With this tweak everything will be preloaded during the battle loading stage.

 

Cons:
This will increase your battle loading times, RAM and GPU RAM usage. Hint: defrag the partition where WoT is installed to optimize loading times.

 

How to install:
Unpack the rar file into your WoT folder overwriting the existing file.

 

How to uninstall:
Delete res\engine_config.xml and rename res\original_engine_config.xml to res\engine_config.xml.

 

Download:

9.6.Tweaked.engine_config.xml.by.Kierrok.v1.rar


Edited by Kierrok, 12 February 2015 - 03:59 AM.


Kierrok #2 Posted 26 December 2014 - 10:23 PM

    Staff Sergeant

  • Player
  • 11523 battles
  • 468
  • Member since:
    03-31-2013
Reserved...

PlazmaKeks #3 Posted 27 December 2014 - 07:53 AM

    Private

  • Player
  • 22921 battles
  • 44
  • [P-M-K] P-M-K
  • Member since:
    06-26-2011
Nice, I'll post this on my blog. GJ Mate...

MaxxyNL #4 Posted 28 December 2014 - 11:36 AM

    Sergeant

  • Player
  • 8830 battles
  • 219
  • Member since:
    04-05-2013

Thanks for this fix. :medal:

 

Keep up the good work! :great:

 

The community has to fix the problems/bugs since Wargaming cannot get it fixed themselves.....



Szaakal #5 Posted 28 December 2014 - 07:31 PM

    Corporal

  • Player
  • 14519 battles
  • 140
  • [-IVI-] -IVI-
  • Member since:
    05-05-2012
Auto exit from time to time, when battle loading. Only for me?

Edited by Szaakal, 28 December 2014 - 07:32 PM.


Gamma_Weapon #6 Posted 28 December 2014 - 07:59 PM

    Private

  • Player
  • 9316 battles
  • 2
  • [PAC] PAC
  • Member since:
    06-02-2011
Just a friendly advice - defragmenting SSD Hard disks will result in shorter lifetimes, SSDHDs do not need defragmenting.

Kierrok #7 Posted 28 December 2014 - 08:47 PM

    Staff Sergeant

  • Player
  • 11523 battles
  • 468
  • Member since:
    03-31-2013

View PostSzaakal, on 28 December 2014 - 07:31 PM, said:

Auto exit from time to time, when battle loading. Only for me?

 

This has been tested since 0.9.0 and the only time that happened was when a friend failed to rename the file when trying to uninstall. But in that case the client never started until he fixed the file name.

But this never been tested with very low specs computers. What's your specs?

 

View PostGamma_Weapon, on 28 December 2014 - 07:59 PM, said:

Just a friendly advice - defragmenting SSD Hard disks will result in shorter lifetimes, SSDHDs do not need defragmenting.

 

True.

Edited by Kierrok, 28 December 2014 - 08:51 PM.


Anton_Hinkel #8 Posted 28 December 2014 - 11:50 PM

    Corporal

  • Player
  • 34143 battles
  • 148
  • [S-W-A] S-W-A
  • Member since:
    05-12-2011

Same here: crash to desktop every 3rd-5th game... False installation as good as impossible, installed via Odem Mortis Modpack

 

Specs:

 

Operating System: Windows 7 Professional 64-bit (6.1, Build 7601) Service Pack 1 (7601.win7sp1_gdr.140706-1506)
Language: German (Regional Setting: German)
Processor: Intel® Xeon® CPU           X5470  @ 3.33GHz (4 CPUs), ~3.3GHz
Memory: 6144MB RAM
Available OS Memory: 6142MB RAM
Page File: 4770MB used, 7513MB available
DirectX Version: DirectX 11
Card name: NVIDIA GeForce GTX 285
Dedicated Memory: 2048 MB
Current Mode: 1920 x 1200 (32 bit) (60Hz)
Driver Name: nvd3dumx.dll,nvwgf2umx.dll,nvwgf2umx.dll,nvd3dum,nvwgf2um,nvwgf2um
Driver File Version: 9.18.0013.4052 (English)
Driver Version: 9.18.13.4052
Driver Attributes: Final Retail
Driver Date/Size: 7/2/2014 21:48:32, 17555104 bytes



Kierrok #9 Posted 29 December 2014 - 12:00 AM

    Staff Sergeant

  • Player
  • 11523 battles
  • 468
  • Member since:
    03-31-2013
That's well above my specs. Sorry guys, it's uninstall for you.

SoWiT #10 Posted 29 December 2014 - 05:15 PM

    Private

  • Player
  • 18815 battles
  • 36
  • [LOOP] LOOP
  • Member since:
    11-26-2011

View PostSzaakal, on 28 December 2014 - 08:31 PM, said:

Auto exit from time to time, when battle loading. Only for me?

 

Same. But im not sure if its causing this.

BirrettaMalefica #11 Posted 29 December 2014 - 05:50 PM

    Captain

  • Player
  • 27686 battles
  • 2,314
  • Member since:
    09-09-2011

View PostAnton_Hinkel, on 28 December 2014 - 11:50 PM, said:

Same here: crash to desktop every 3rd-5th game... False installation as good as impossible, installed via Odem Mortis Modpack

 

Specs:

 

Operating System: Windows 7 Professional 64-bit (6.1, Build 7601) Service Pack 1 (7601.win7sp1_gdr.140706-1506)
Language: German (Regional Setting: German)
Processor: Intel® Xeon® CPU           X5470  @ 3.33GHz (4 CPUs), ~3.3GHz
Memory: 6144MB RAM
Available OS Memory: 6142MB RAM
Page File: 4770MB used, 7513MB available
DirectX Version: DirectX 11
Card name: NVIDIA GeForce GTX 285
Dedicated Memory: 2048 MB
Current Mode: 1920 x 1200 (32 bit) (60Hz)
Driver Name: nvd3dumx.dll,nvwgf2umx.dll,nvwgf2umx.dll,nvd3dum,nvwgf2um,nvwgf2um
Driver File Version: 9.18.0013.4052 (English)
Driver Version: 9.18.13.4052
Driver Attributes: Final Retail
Driver Date/Size: 7/2/2014 21:48:32, 17555104 bytes

make a screenshot about system ram,cpu etc usage when you are going to crash, 4-5th game

 

btw , wot require directx9


Edited by BirrettaMalefica, 29 December 2014 - 05:51 PM.


ucramos #12 Posted 29 December 2014 - 07:43 PM

    Staff Sergeant

  • Player
  • 44932 battles
  • 311
  • Member since:
    03-30-2013

I use this for more than 4 or 5 months and it works flawlessly.

 

This was beta tested on a group of friends and never caused any CTD problems.


Edited by ucramos, 29 December 2014 - 07:49 PM.


Tau_Atreus #13 Posted 31 December 2014 - 10:55 PM

    Private

  • Player
  • 13821 battles
  • 3
  • [VERSA] VERSA
  • Member since:
    04-24-2012

View PostKierrok, on 29 December 2014 - 12:00 AM, said:

That's well above my specs. Sorry guys, it's uninstall for you.

 

Do you mean those Pc specs are too high for your fix to work ?

Edited by Tau_Atreus, 31 December 2014 - 10:56 PM.


Kierrok #14 Posted 01 January 2015 - 12:35 AM

    Staff Sergeant

  • Player
  • 11523 battles
  • 468
  • Member since:
    03-31-2013

View PostTau_Atreus, on 31 December 2014 - 10:55 PM, said:

 

Do you mean those Pc specs are too high for your fix to work ?

 

No, I meant those specs are higher than mine. I was expecting some problems with lower specs, like too few RAM and/or GPU RAM, not with higher specs...

 

Happy New Year!



Kazzragore #15 Posted 01 January 2015 - 01:48 AM

    Major

  • Beta Tester
  • 26925 battles
  • 2,990
  • [-DPG] -DPG
  • Member since:
    11-18-2010

View PostAnton_Hinkel, on 28 December 2014 - 11:50 PM, said:

Same here: crash to desktop every 3rd-5th game... False installation as good as impossible, installed via Odem Mortis Modpack

 

Specs:

 

Operating System: Windows 7 Professional 64-bit (6.1, Build 7601) Service Pack 1 (7601.win7sp1_gdr.140706-1506)
Language: German (Regional Setting: German)
Processor: Intel® Xeon® CPU           X5470  @ 3.33GHz (4 CPUs), ~3.3GHz
Memory: 6144MB RAM
Available OS Memory: 6142MB RAM
Page File: 4770MB used, 7513MB available
DirectX Version: DirectX 11
Card name: NVIDIA GeForce GTX 285
Dedicated Memory: 2048 MB
Current Mode: 1920 x 1200 (32 bit) (60Hz)
Driver Name: nvd3dumx.dll,nvwgf2umx.dll,nvwgf2umx.dll,nvd3dum,nvwgf2um,nvwgf2um
Driver File Version: 9.18.0013.4052 (English)
Driver Version: 9.18.13.4052
Driver Attributes: Final Retail
Driver Date/Size: 7/2/2014 21:48:32, 17555104 bytes

 

same here, uninstalled this fix and no crash anymore.

trulez1 #16 Posted 01 January 2015 - 01:48 AM

    Private

  • Player
  • 11160 battles
  • 16
  • Member since:
    10-30-2011

As far as I can tell, there's only 3 changes made to the default settings.

 

<maxFrameRate>    120    </maxFrameRate>

was 60

 

<reducedFrameRate>    60    </reducedFrameRate>

was 30

 

<enforcePreloads>    true    </enforcePreloads>

was false

 

Please list any other changes you've made so we can have a better overview what this new config tries to do.



HirogenYao #17 Posted 01 January 2015 - 09:47 AM

    Private

  • Player
  • 4859 battles
  • 7
  • [D0GE] D0GE
  • Member since:
    05-31-2012

Went ahead and installed this mod, and it seems to alleviate some microstutters i was having. The game has a tendency to lock up during loading, but it happens so rarely ( once every 50 battles) i can't reproduce nor narrow down the cause of it.

 

Specs Spoiler

 


Edited by HirogenYao, 01 January 2015 - 09:48 AM.


Yasharah #18 Posted 01 January 2015 - 01:52 PM

    Second Lieutenant

  • Player
  • 16962 battles
  • 1,269
  • Member since:
    08-19-2011

View PostHirogenYao, on 01 January 2015 - 09:47 AM, said:

Went ahead and installed this mod, and it seems to alleviate some microstutters i was having. The game has a tendency to lock up during loading, but it happens so rarely ( once every 50 battles) i can't reproduce nor narrow down the cause of it.

 

Specs Spoiler

 

 

we had the same problem with a user of our modpack and the cause was a damaged vehicles.pkg in the res/packages folder. it was the vehicles_german.pkg and the problem occurred with one tank only so it didnt happen that often

Edited by Yasharah, 01 January 2015 - 01:54 PM.


Kierrok #19 Posted 01 January 2015 - 06:21 PM

    Staff Sergeant

  • Player
  • 11523 battles
  • 468
  • Member since:
    03-31-2013

View Posttrulez1, on 01 January 2015 - 01:48 AM, said:

As far as I can tell, there's only 3 changes made to the default settings.

 

<maxFrameRate>    120    </maxFrameRate>

was 60

 

<reducedFrameRate>    60    </reducedFrameRate>

was 30

 

<enforcePreloads>    true    </enforcePreloads>

was false

 

Please list any other changes you've made so we can have a better overview what this new config tries to do.

 

I didn't change maxFrameRate nor reducedFrameRate. Those are the original values.

I did change enforcePreloads and added the preload setting to almost all the soundbanks projects.

 

I have to restart the client after ~20 battles because the fps goes slightly down battle after battle. They start at about 50-60 fps in the first battle and at some point I end up with 15-18 fps and I know it's time to restart the client. But this happened before this tweak too.



Kierrok #20 Posted 12 February 2015 - 03:59 AM

    Staff Sergeant

  • Player
  • 11523 battles
  • 468
  • Member since:
    03-31-2013
Updated to 0.9.6.





Also tagged with tweak, fix, micro, freezes

1 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users