Jump to content


[0.9.20.0] GTO's MLG Mod continued by Aimdrol | Illuminati scheming again!

MLG 420 blaze it hitmarker swag doritos 6th sense yolo illuminati 8/8

  • Please log in to reply
321 replies to this topic

Aim_Drol #301 Posted 16 March 2017 - 05:28 PM

    Lieutenant

  • Player
  • 22270 battles
  • 1,770
  • [S3AL] S3AL
  • Member since:
    08-10-2011

View PostAslain, on 15 March 2017 - 09:29 AM, said:

 

Thank you for update, could you tell if normal behaviour that after a player receives in-game award it always stays on screen under enemy player's panel for the rest of battle?

 

It's not. Gotta check what's wrong there.

 

View PostWillster419_NA, on 16 March 2017 - 12:42 PM, said:

Your installer extracts to 0.9.17.1 as well as 0.9.17.0.1, i'm guessing this is not the intent.

Also the engine_config.xml is only extracted into 0.9.17.0.1

For some reason this one 0.19.17.0.1 did not get replaced by 0.9.17.1 in the installer script. It's fixed now.



Yastrab #302 Posted 16 March 2017 - 11:32 PM

    Private

  • Player
  • 1721 battles
  • 1
  • Member since:
    03-04-2017

Hi, I have a problem with Daniel voice, the voice notifications (e.g. target locked, learn to aim scrub etc...) work only ~40% of the time, other 60% of the game I get no voice notifications at all. But voice notifications at the start of battle (e.g. tomato team again, let's go) and when I get destroyed work 100%. Also all other features of the mod ( marks of excellence, companion) work without problem.

I tried to reinstall mod either with installer and by unpacking ZIP from Github, but it didn't solve the problem.

I have no other mods installed (and never had any).

I tried to find something in python.log and all errors I get is this error [SOUND_ERROR] Sound fail: 3944980085 - ErrorCode: 15 ( the 10 digit number is different each time),

and also there warnings WARNING: [WARNING] (scripts/client/account_helpers/CustomFilesCache.py, 36): Method "__run_read" takes too much time 0.101999998093

Any ideas what did I do wrong (or what went wrong) ? Thanks.

 

Oh and also a big thanks for doing what you're doing, I really enjoy this mod.

 

 


Edited by Yastrab, 16 March 2017 - 11:32 PM.


Aim_Drol #303 Posted 17 March 2017 - 08:27 PM

    Lieutenant

  • Player
  • 22270 battles
  • 1,770
  • [S3AL] S3AL
  • Member since:
    08-10-2011
I also have this issue sometimes but I cannot figure out why it's not working. For some reason the games sometimes cannot find the sound event (resulting in the SOUND_ERROR) although it can find it just fine at other times. I tried playing around with the values Willster suggested but that did not help.
 
 


Willster419_NA #304 Posted 07 April 2017 - 04:27 AM

    Corporal

  • Player
  • 10 battles
  • 186
  • Member since:
    02-25-2017

I have noticed this as well. The reason that some sounds work 100% of the time is because they are from a different sound bank, MLG.bnk vs voiceover.bnk. I think that some like the vehicle destroyed are in voiceover.bnk, so why those are working 100% but the penetration sounds don't baffles me. What I find interesting is that my sound mod has more sound files than yours, yet yours is having the errors and not mine: I decided to analyze the difference between your sound mods and my sound mods. We both use the same event names, and we both (i assume) use the same version of wwise, and the same conversion settings as stated in the korean random sound thread post. However, there are two key differences:

My sound mod audio bank (in file name and in wwise sound bank name) name is RelHaxVoiceover.bnk, and I load it from engine_config.xml as <name>RelHaxVoiceover.bnk</name>, and remove the voiceover.bnk refrence

Your sound mod audio bank name is voiceover.bnk, and you load it from engine_config.xml as the standard voiceover.bnk

 

It could be theorized that it is trying to load both bnk files and is eithor (a) running out of sound pool memmory or (b) is not liking two sound events being loaded in the same sound bank name, but having different ID's. You could try renaming your sound bank from voiceover.bnk to something like MLGvoiceover.bnk, file name and wwise soundbank name.

 

I will continue to research further into this, but here are some other possible options:

(along with changing the project name) Try loading the mod bank from audio_mods.xml instead and not souce engine_config.xml at all.

(along with the above) remap every event for audio_mods.xml. I know it will be a long and painfull process, but I can at least provide a started version, one in xml node format and the other with events spaced out. Taken from simple crew sounds mod:

 

What I suggested worked for my mod, I assumed it would work for your mod, but I was wrong, my bad, i should have tested it first.

Attached Files

  • Attached File   audio_mods_node.xml   7.22K
  • Attached File   audio_mods_spaced.xml   9.27K

Edited by Willster419_NA, 07 April 2017 - 04:29 AM.


HemanathanRX7 #305 Posted 13 May 2017 - 08:54 AM

    Private

  • Player
  • 0 battles
  • 4
  • Member since:
    10-25-2013
Will the MLG modpack be updated for 9.18? Looking forward to using it on my new desktop

Aim_Drol #306 Posted 13 May 2017 - 03:24 PM

    Lieutenant

  • Player
  • 22270 battles
  • 1,770
  • [S3AL] S3AL
  • Member since:
    08-10-2011
I am currently busy with my Replay Analyzer and a lot of other stuff, so it might take a while. But yes it will be updated eventually.

HemanathanRX7 #307 Posted 17 May 2017 - 04:54 PM

    Private

  • Player
  • 0 battles
  • 4
  • Member since:
    10-25-2013

View PostAim_Drol, on 13 May 2017 - 02:24 PM, said:

I am currently busy with my Replay Analyzer and a lot of other stuff, so it might take a while. But yes it will be updated eventually.

 

Thanks for your hard work in making mods, will wait for it eagerly :D

iFartCheese #308 Posted 01 June 2017 - 04:32 PM

    Private

  • Player
  • 274 battles
  • 1
  • Member since:
    10-22-2016
Doesn`t work for 9.19 :( 

HemanathanRX7 #309 Posted 02 June 2017 - 08:15 AM

    Private

  • Player
  • 0 battles
  • 4
  • Member since:
    10-25-2013

View PostiFartCheese, on 01 June 2017 - 03:32 PM, said:

Doesn`t work for 9.19 :( 

 

That's because its updated only for 9.17 genius..

DeltaOperator #310 Posted 07 June 2017 - 03:32 PM

    Brigadier

  • Player
  • 20920 battles
  • 4,285
  • Member since:
    03-16-2014
I am looking forward to seeing the dankness of this modpack in the future once again.

shadowmen11 #311 Posted 17 July 2017 - 07:34 PM

    Staff Sergeant

  • Player
  • 23186 battles
  • 370
  • Member since:
    05-25-2012
there is a chance for update, in the future?

Grumpelumpf #312 Posted 18 July 2017 - 11:53 PM

    Lieutenant

  • Beta Tester
  • 44140 battles
  • 1,840
  • Member since:
    10-25-2010

Hi Aim_Drol,

 

SixthSense Mod is working, but in combination with XVM, the personal SixthSense status will not be provided via XMQP.

 

Will be nice to be fixed if you could afford the time.

 

thx in afvance

Grumpelumpf



Aim_Drol #313 Posted 31 July 2017 - 04:50 PM

    Lieutenant

  • Player
  • 22270 battles
  • 1,770
  • [S3AL] S3AL
  • Member since:
    08-10-2011

View PostGrumpelumpf, on 18 July 2017 - 11:53 PM, said:

Hi Aim_Drol,

 

SixthSense Mod is working, but in combination with XVM, the personal SixthSense status will not be provided via XMQP.

 

Will be nice to be fixed if you could afford the time.

 

thx in afvance

Grumpelumpf

I actually have not seen this new xvm feature due to my hiatus from the game. I'll see what I can do about it.

 

 

Ok guys, I finally have free time again and I will start updating the mod for the current patch.



Aim_Drol #314 Posted 03 August 2017 - 06:39 PM

    Lieutenant

  • Player
  • 22270 battles
  • 1,770
  • [S3AL] S3AL
  • Member since:
    08-10-2011

A preliminary update for 9.19.1.1 is available now.

The 6th sense mod does still break the personal 6th sense status thing from xvm and RTAN's message still does not disappear properly. That's stuff that I will work on fixing the next couple of days.



Grumpelumpf #315 Posted 07 August 2017 - 09:13 PM

    Lieutenant

  • Beta Tester
  • 44140 battles
  • 1,840
  • Member since:
    10-25-2010

View PostAim_Drol, on 03 August 2017 - 06:39 PM, said:

A preliminary update for 9.19.1.1 is available now.

The 6th sense mod does still break the personal 6th sense status thing from xvm and RTAN's message still does not disappear properly. That's stuff that I will work on fixing the next couple of days.

 

Hi Aim_Drol,

 

budyx69 fixed your Sixth Sense script.

 

have fun

Grump

 

 

 

 

Attached Files

  • Attached File   mod_sixthSense.zip   2.38K


Aim_Drol #316 Posted 09 August 2017 - 12:34 AM

    Lieutenant

  • Player
  • 22270 battles
  • 1,770
  • [S3AL] S3AL
  • Member since:
    08-10-2011
I updated the 6th sense mod with the fixed script and also fixed some outdated strings in the localization files.

Aim_Drol #317 Posted 23 August 2017 - 05:49 PM

    Lieutenant

  • Player
  • 22270 battles
  • 1,770
  • [S3AL] S3AL
  • Member since:
    08-10-2011
The mod has been updated for 9.19.1.2 and further fixes from budyx69 for the 6th sense mod have been applied.

Aslain #318 Posted 27 August 2017 - 09:25 AM

    Field Marshal

  • Beta Tester
  • 14599 battles
  • 10,248
  • Member since:
    07-20-2010
animated sixthSense stopped to work in last update

Aim_Drol #319 Posted 27 August 2017 - 05:22 PM

    Lieutenant

  • Player
  • 22270 battles
  • 1,770
  • [S3AL] S3AL
  • Member since:
    08-10-2011
It'll probably take me a while to fix this, I don't really have time for it in the next weeks.

firedani #320 Posted 30 August 2017 - 03:21 PM

    Lance-corporal

  • Player
  • 10798 battles
  • 66
  • Member since:
    03-28-2013
Does it work with 9.20? Has anyone tested?




1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users