Jump to content


massive fps issues on high end PC

fps performance

  • Please log in to reply
8 replies to this topic

SanderCokart #1 Posted 13 December 2015 - 10:59 PM

    Private

  • Player
  • 7149 battles
  • 8
  • Member since:
    11-25-2013

Okay im confused since i see youtuber's with similar or worse hardware then I have and they get 60 fps all the time or more.

And i get with my:


-GPU: Nvidia Geforce GTX 970 (GV-N970G1 GAMING-4GD)

-CPU: Intel® Core™ i7-4770K CPU @ 3.50GHz "Not Overclocked"

-Memory: 12 GB RAM DDR3

-Motherboard: GIGABYTE G1.Sniper.M5

 

very bad Framerates just dropping to 40 and 30. internet is also no issue since we have 50 mbps download & upload with 10 ~ 20 ms latency

and another guy in game also said he is running the HD version of WoT on maximum with the 970 from MSI and a 6700K skylake and some 16 gb of DDR4 @90 fps

but still I know my system is not weak because i can run any other AAA title just fine 80 fps maximum settings including Witcher 3, Fallout 4, and so on


Edited by UniversalGamerTV, 13 December 2015 - 10:59 PM.


Effing_Drako #2 Posted 14 December 2015 - 12:06 AM

    Lieutenant General

  • Player
  • 26997 battles
  • 7,662
  • [-GLO-] -GLO-
  • Member since:
    04-11-2011
Do you have Vsync turned on?

SanderCokart #3 Posted 14 December 2015 - 12:58 AM

    Private

  • Player
  • 7149 battles
  • 8
  • Member since:
    11-25-2013
Tried both and with its worse and yes i know why that is but its not the issue

K_A #4 Posted 14 December 2015 - 12:17 PM

    Brigadier

  • Player
  • 13651 battles
  • 4,665
  • [T-D-U] T-D-U
  • Member since:
    04-18-2013
What resolution are u playing at? 

SanderCokart #5 Posted 14 December 2015 - 03:16 PM

    Private

  • Player
  • 7149 battles
  • 8
  • Member since:
    11-25-2013
1080p of course

daddlar #6 Posted 14 December 2015 - 04:25 PM

    Warrant Officer

  • Player
  • 29291 battles
  • 924
  • [D0NG] D0NG
  • Member since:
    01-11-2013

How many memory-sticks is in the system?

 

The mobo doesn't support triple channel memory.



SanderCokart #7 Posted 14 December 2015 - 05:00 PM

    Private

  • Player
  • 7149 battles
  • 8
  • Member since:
    11-25-2013

1 x 4

1 x 8

@1333 Mhz



Xino9922 #8 Posted 17 December 2015 - 01:27 PM

    Brigadier

  • Player
  • 16048 battles
  • 4,736
  • [LEWD] LEWD
  • Member since:
    02-13-2011

View PostUniversalGamerTV, on 13 December 2015 - 10:59 PM, said:

Okay im confused since i see youtuber's with similar or worse hardware then I have and they get 60 fps all the time or more.

And i get with my:

-GPU: Nvidia Geforce GTX 970 (GV-N970G1 GAMING-4GD)

-CPU: Intel® Core™ i7-4770K CPU @ 3.50GHz "Not Overclocked"

-Memory: 12 GB RAM DDR3

-Motherboard: GIGABYTE G1.Sniper.M5

 

very bad Framerates just dropping to 40 and 30. internet is also no issue since we have 50 mbps download & upload with 10 ~ 20 ms latency

and another guy in game also said he is running the HD version of WoT on maximum with the 970 from MSI and a 6700K skylake and some 16 gb of DDR4 @90 fps

but still I know my system is not weak because i can run any other AAA title just fine 80 fps maximum settings including Witcher 3, Fallout 4, and so on

 

Weird, had the same kinda issues after the 9.10 patch. Next patch/hotfix fixed it again.

Also, a reinstall of my PC helped greatly, probably a bad driver or something...

 

Tried updating to the latest Nvidia driver? Especially on windows 10 that might be an issue, incompitable drivers...

Also, must mentioned aged engine and massive pathwork that WG has done makes engine kinda unstable and shite. Sheeps engine is much better and improved over tonks engine...


Edited by Xino9922, 17 December 2015 - 01:28 PM.


SanderCokart #9 Posted 17 December 2015 - 04:24 PM

    Private

  • Player
  • 7149 battles
  • 8
  • Member since:
    11-25-2013

A person like me is always up-to-date with his drivers

and Clean installs them too







Also tagged with fps, performance

1 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users