Jump to content


Fps not go up and graphics go down

fps lag gtx 750 ti graphics problem

  • Please log in to reply
3 replies to this topic

FiN_pet777 #1 Posted 03 February 2016 - 08:33 PM

    Private

  • Player
  • 29134 battles
  • 46
  • [-PJ-] -PJ-
  • Member since:
    06-19-2012

My friend got new gpu, gtx 750 ti and when he plays wot he gets like 30 fps on low, med, high settings etc. He should be able to play atleast 50 - 60 fps on medium settings! Pls tell if you know anything.

 

Here is his full specs; Intel core 2 duo E6600, 4gb ram, gtx 750 ti and lga 775 motherboard. His ingame wot is Keke_10, you can private message him in wot and also reply here, if you got any ideas



K_A #2 Posted 03 February 2016 - 11:02 PM

    Brigadier

  • Player
  • 13643 battles
  • 4,665
  • [T-D-U] T-D-U
  • Member since:
    04-18-2013
That CPU is the problem. It seems it can't push out more than 30 fps so regardless of the graphics quality the GPU outputs the total fps will only be 30. 

CroustibatFR #3 Posted 04 February 2016 - 12:18 PM

    Brigadier

  • Player
  • 23297 battles
  • 4,135
  • Member since:
    09-14-2011

View PostK_A, on 03 February 2016 - 11:02 PM, said:

That CPU is the problem. It seems it can't push out more than 30 fps so regardless of the graphics quality the GPU outputs the total fps will only be 30. 

 

Agree on that.

 

The E6600 was an entry level cpu, and it entered the market ... ten years ago. Basically the GPU renders the image with textures and all, but the CPU handles the underlying geometry. No FPS increase when lowering effects means the bottleneck is the CPU.

You can get more FPS by lowering resolution in that case. He should be able to play in low resolution & medium / high details.

 

Also, you might want to check wether the fps have not just been capped in the drivers.



FiN_pet777 #4 Posted 04 February 2016 - 01:36 PM

    Private

  • Player
  • 29134 battles
  • 46
  • [-PJ-] -PJ-
  • Member since:
    06-19-2012
okey thx





Also tagged with fps, lag, gtx 750 ti, graphics, problem

1 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users