Jump to content


[1.7.0.2] YasenKrasen Colored Messages [ENG] + session statistics [MULTI] [19.12.2019]

YasenKrasen Session Stats Statistics Session Statistics Colored Messages 1.7.0.2

  • Please log in to reply
1473 replies to this topic

Poll: [1.7.0.2] YasenKrasen Colored Messages [ENG] + session statistics [MULTI] [19.12.2019] (1685 members have cast votes)

What Version of YasenKrasen You are using?

  1. Voted Core (641 votes [38.04%] - View)

    Percentage of vote: 38.04%

  2. Voted Vanilla (716 votes [42.49%] - View)

    Percentage of vote: 42.49%

  3. Voted Base (328 votes [19.47%] - View)

    Percentage of vote: 19.47%

What addon's for YasenKrasen You are using?

  1. Voted Alternative In-game battle messages (Skulls) (433 votes [20.88%] - View)

    Percentage of vote: 20.88%

  2. Voted Graphical Battle Messages (450 votes [21.70%] - View)

    Percentage of vote: 21.70%

  3. Voted Additional backgrounds (303 votes [14.61%] - View)

    Percentage of vote: 14.61%

  4. Voted None addon's (888 votes [42.82%] - View)

    Percentage of vote: 42.82%

Vote Guests cannot vote Hide poll

Todeskult #1381 Posted 12 December 2019 - 08:20 PM

    Second Lieutenant

  • Player
  • 34280 battles
  • 1,174
  • [GTCHA] GTCHA
  • Member since:
    07-22-2012

I know that it is no exactly a "bug" but rather a description "issue", just spotted this and thought about posting the fact here ;)

Thanks!



ArramisRo #1382 Posted 13 December 2019 - 12:26 AM

    Private

  • Player
  • 19105 battles
  • 5
  • [A--B] A--B
  • Member since:
    02-22-2013

for me stopped at 6/10 battles - refused to update.

LOG:

 2019-12-13 01:18:57.020: INFO: Loading mod: YasenKrasen Session Statistics 1.7.0.0 (http://forum.worldoftanks.eu/index.php?/topic/583433-)
2019-12-13 01:18:57.023: ERROR: [EXCEPTION] (mod_stat, 1):
Traceback (most recent call last):
  File "mod_stat", line 1, in readConfig
  File "mod_stat", line 1, in loadJsonFile
  File "scripts/common/Lib/json/__init__.py", line 338, in loads
  File "scripts/common/Lib/json/decoder.py", line 366, in decode
  File "scripts/common/Lib/json/decoder.py", line 382, in raw_decode
ValueError: Expecting ',' delimiter: line 1 column 85 (char 84)

2019-12-13 01:18:57.023: INFO: [YasenKrasen mod_stat] load config.json has failed
2019-12-13 01:18:57.024: INFO: [SL_PRO] Skipped Script in res_mods folder: mod_stat.pyc
2019-12-13 01:18:57.024: INFO: 
2019-12-13 01:18:57.024: ERROR: [EXCEPTION] (<string>, 550):
Traceback (most recent call last):
  File "<string>", line 536, in _findValidMODs
  File "scripts/common/Lib/importlib/__init__.py", line 37, in import_module
  File "mod_stat", line 1, in <pjorion_obfuscated>
AttributeError: 'SessionStatistic' object has no attribute 'useMessenger'

 

2019-12-13 01:19:41.250: ERROR: [EXCEPTION] (scripts/client/gui/shared/event_bus.py, 47):
Traceback (most recent call last):
  File "scripts/client/gui/shared/event_bus.py", line 45, in handleEvent
  File "mod_stat", line 1, in yk_handleLobbyViewLoaded
TypeError: 'NoneType' object is not callable

 

Error:
  ScriptLoader PRO v1.36:

Error by executing script(s):
mod_stat.pyc

Check python logfile for detailed informations
[ H:\World_of_Tanks_EU/Python.log ]


Edited by ArramisRo, 13 December 2019 - 12:32 AM.


Scanmen #1383 Posted 13 December 2019 - 07:59 AM

    Sergeant

  • Player
  • 26414 battles
  • 278
  • [WNB] WNB
  • Member since:
    10-14-2011

View PostArramisRo, on 13 December 2019 - 12:26 AM, said:

for me stopped at 6/10 battles - refused to update.

LOG:

 2019-12-13 01:18:57.020: INFO: Loading mod: YasenKrasen Session Statistics 1.7.0.0 (http://forum.worldoftanks.eu/index.php?/topic/583433-)
2019-12-13 01:18:57.023: ERROR: [EXCEPTION] (mod_stat, 1):
Traceback (most recent call last):
  File "mod_stat", line 1, in readConfig
  File "mod_stat", line 1, in loadJsonFile
  File "scripts/common/Lib/json/__init__.py", line 338, in loads
  File "scripts/common/Lib/json/decoder.py", line 366, in decode
  File "scripts/common/Lib/json/decoder.py", line 382, in raw_decode
ValueError: Expecting ',' delimiter: line 1 column 85 (char 84)

2019-12-13 01:18:57.023: INFO: [YasenKrasen mod_stat] load config.json has failed
2019-12-13 01:18:57.024: INFO: [SL_PRO] Skipped Script in res_mods folder: mod_stat.pyc
2019-12-13 01:18:57.024: INFO: 
2019-12-13 01:18:57.024: ERROR: [EXCEPTION] (<string>, 550):
Traceback (most recent call last):
  File "<string>", line 536, in _findValidMODs
  File "scripts/common/Lib/importlib/__init__.py", line 37, in import_module
  File "mod_stat", line 1, in <pjorion_obfuscated>
AttributeError: 'SessionStatistic' object has no attribute 'useMessenger'

 

2019-12-13 01:19:41.250: ERROR: [EXCEPTION] (scripts/client/gui/shared/event_bus.py, 47):
Traceback (most recent call last):
  File "scripts/client/gui/shared/event_bus.py", line 45, in handleEvent
  File "mod_stat", line 1, in yk_handleLobbyViewLoaded
TypeError: 'NoneType' object is not callable

 

Error:
  ScriptLoader PRO v1.36:

Error by executing script(s):
mod_stat.pyc

Check python logfile for detailed informations
[ H:\World_of_Tanks_EU/Python.log ]

 

I think you made a mistake while editing the config.json file. Download the original file again and it will work. ;)



Ober__ #1384 Posted 13 December 2019 - 08:53 AM

    Warrant Officer

  • Player
  • 63911 battles
  • 848
  • [KAZNA] KAZNA
  • Member since:
    09-01-2014
enough to change only folder name for this new christmas patch?

Dado_Ze #1385 Posted 13 December 2019 - 06:09 PM

    Warrant Officer

  • Player
  • 75733 battles
  • 567
  • Member since:
    06-05-2012

Archive paths updated for 1.7.0.1

 

View PostOber__, on 13 December 2019 - 09:53 AM, said:

enough to change only folder name for this new christmas patch?

 

Yup, there is no crucial changes in game for the mod.



Ober__ #1386 Posted 19 December 2019 - 06:44 PM

    Warrant Officer

  • Player
  • 63911 battles
  • 848
  • [KAZNA] KAZNA
  • Member since:
    09-01-2014
once again, enough to change folder name?

Quaksen #1387 Posted 19 December 2019 - 06:48 PM

    Lieutenant

  • Player
  • 25831 battles
  • 1,648
  • [KLKMP] KLKMP
  • Member since:
    03-29-2013

View PostOber__, on 19 December 2019 - 06:44 PM, said:

once again, enough to change folder name?

Should be enough.

The text changes in the micropatch is just related to the end-of-December Twitch care package Lima, as far as I noticed.



Dado_Ze #1388 Posted 19 December 2019 - 08:24 PM

    Warrant Officer

  • Player
  • 75733 battles
  • 567
  • Member since:
    06-05-2012

Updated for 1.7.0.2

Happy hunting :)

 

View PostOber__, on 19 December 2019 - 07:44 PM, said:

once again, enough to change folder name?

 

Depends what version you are using, for Base version folder change would be enough and maybe disable mod update notification.

If you are using Core or Vanilla then it's safer to use updated mod version.



TankSchmidt #1389 Posted 20 December 2019 - 11:46 PM

    General

  • Player
  • 25258 battles
  • 9,253
  • [-GLO-] -GLO-
  • Member since:
    06-03-2011

Just pointing out that the sexy "Da Stats" config has worked with all the updates and still does :hiding:

 

PS: Thx to Dado for all his work and Merry Christmas to all!



Ober__ #1390 Posted 25 December 2019 - 09:27 PM

    Warrant Officer

  • Player
  • 63911 battles
  • 848
  • [KAZNA] KAZNA
  • Member since:
    09-01-2014

I think I have a problem with this mod- after the battle game is frozen in moment "Loading to garage". If you die before battle ends and go to garage, everything is ok, but after the of the battle game everytime frozen. Today I have updated only XVM and Yasenrasen. Installed old XVM version, problem still appears. Yesterday I had not any problem...


Edited by Ober__, 25 December 2019 - 09:28 PM.


LincolnHawk #1391 Posted 25 December 2019 - 09:52 PM

    Private

  • Player
  • 39288 battles
  • 3
  • [W3RNG] W3RNG
  • Member since:
    09-09-2012

View PostOber__, on 25 December 2019 - 09:27 PM, said:

I think I have a problem with this mod- after the battle game is frozen in moment "Loading to garage". If you die before battle ends and go to garage, everything is ok, but after the of the battle game everytime frozen. Today I have updated only XVM and Yasenrasen. Installed old XVM version, problem still appears. Yesterday I had not any problem...

 

i have the same problem....



Ober__ #1392 Posted 25 December 2019 - 10:26 PM

    Warrant Officer

  • Player
  • 63911 battles
  • 848
  • [KAZNA] KAZNA
  • Member since:
    09-01-2014
without this mode everything is perfect.
21:27 Added after 0 minute
played already 7 games, no problems at all without it.

Ma7rix #1393 Posted 26 December 2019 - 08:24 AM

    Staff Sergeant

  • Player
  • 65921 battles
  • 349
  • [OISPA] OISPA
  • Member since:
    11-22-2012
I can confirm the problem came 1st time esterday, removed it and installed again and seems to work? tried all kind of things, removed game cache files etc. I think this mod is the problem.

Stefan86s #1394 Posted 26 December 2019 - 04:51 PM

    Private

  • Player
  • 31100 battles
  • 5
  • Member since:
    01-15-2015

Confirm, game freezes if i wait the battle to end.

Core version. 



Ma7rix #1395 Posted 26 December 2019 - 05:34 PM

    Staff Sergeant

  • Player
  • 65921 battles
  • 349
  • [OISPA] OISPA
  • Member since:
    11-22-2012
can you try remove and add it again? because mine seems to work after doing that. I use vanilla version. I also removed  Unanonymizer on battle results by RaJCeL, because 1st  I tough this is conflicting it or something.

Edited by Ma7rix, 26 December 2019 - 05:34 PM.


Ober__ #1396 Posted 26 December 2019 - 06:25 PM

    Warrant Officer

  • Player
  • 63911 battles
  • 848
  • [KAZNA] KAZNA
  • Member since:
    09-01-2014
I reinstalled all mods several times, didn't helped. By the way I used Vanilla version.

Ma7rix #1397 Posted 26 December 2019 - 07:34 PM

    Staff Sergeant

  • Player
  • 65921 battles
  • 349
  • [OISPA] OISPA
  • Member since:
    11-22-2012
Mine has been working now, weird....

Ma7rix #1398 Posted 26 December 2019 - 08:47 PM

    Staff Sergeant

  • Player
  • 65921 battles
  • 349
  • [OISPA] OISPA
  • Member since:
    11-22-2012

problem started again,  but I played almost 20-30 games ok ..

 

edit :python log attached.

Attached Files

  • Attached File   python.zip   147.12K

Edited by Ma7rix, 27 December 2019 - 09:43 AM.


Aslain #1399 Posted 27 December 2019 - 08:43 AM

    Field Marshal

  • Beta Tester
  • 14600 battles
  • 12,745
  • Member since:
    07-20-2010
If you guys want to help, I suggest to attach python.log to the post, otherwise it's not much of info. It's also very important to enable debugging in the YK config file: mods\configs\yk-stats\config.json before you play, that will add additional information to logs, that can be crucial to the author.

Scanmen #1400 Posted 27 December 2019 - 10:52 AM

    Sergeant

  • Player
  • 26414 battles
  • 278
  • [WNB] WNB
  • Member since:
    10-14-2011

The base version works flawlessly. 

Use ScriptLoader Pro mod, to find errors.


Edited by Scanmen, 27 December 2019 - 10:55 AM.





8 user(s) are reading this topic

1 members, 7 guests, 0 anonymous users


    PzSniper