Jump to content


[1.7.0.2] YasenKrasen Colored Messages [ENG] + session statistics [MULTI] [19.12.2019]

YasenKrasen Session Stats Statistics Session Statistics Colored Messages 1.7.0.2

  • Please log in to reply
1514 replies to this topic

Poll: [1.7.0.2] YasenKrasen Colored Messages [ENG] + session statistics [MULTI] [19.12.2019] (1691 members have cast votes)

What Version of YasenKrasen You are using?

  1. Voted Core (644 votes [38.08%] - View)

    Percentage of vote: 38.08%

  2. Voted Vanilla (717 votes [42.40%] - View)

    Percentage of vote: 42.40%

  3. Voted Base (330 votes [19.52%] - View)

    Percentage of vote: 19.52%

What addon's for YasenKrasen You are using?

  1. Voted Alternative In-game battle messages (Skulls) (434 votes [20.87%] - View)

    Percentage of vote: 20.87%

  2. Voted Graphical Battle Messages (450 votes [21.63%] - View)

    Percentage of vote: 21.63%

  3. Voted Additional backgrounds (304 votes [14.62%] - View)

    Percentage of vote: 14.62%

  4. Voted None addon's (892 votes [42.88%] - View)

    Percentage of vote: 42.88%

Vote Guests cannot vote Hide poll

games0124 #161 Posted 15 December 2016 - 12:41 PM

    Private

  • Player
  • 0 battles
  • 11
  • Member since:
    11-18-2016
How come the background shows as purple but the number shows as blue? This didn't happen in the previous version. 2638 should be purple/unicum according to wotlabs and the previous version of this mod. Same problem also for battle stats. 
Spoiler

 


Edited by games0124, 15 December 2016 - 12:43 PM.


Dado_Ze #162 Posted 15 December 2016 - 01:45 PM

    Warrant Officer

  • Player
  • 75733 battles
  • 567
  • Member since:
    06-05-2012

View Postgames0124, on 15 December 2016 - 12:41 PM, said:

How come the background shows as purple but the number shows as blue? This didn't happen in the previous version. 2638 should be purple/unicum according to wotlabs and the previous version of this mod. Same problem also for battle stats.

 

There is no difference between 0.9.16 and current version in color scale or you mean with "previous" some earlier version?

Its really strange that the background shows different color then actual wn8, according the default config it should be same color...will be checked.

 

I changed the color scale in config at 0.9.16, i used the scale from wotlabs colors.xc, could be outdated....

Anyway I doubt that it could be incorrect, and would like to get suggested what should I use for default color scale in config, when possible with official links to the color scale, so I can update it regularly ...

 

I didn't pay attention to how the mod shows the colors, <value = color or >value = color...need to be checked.

 

In mean time till its updated/fixed, you can change the color scale in 'res_mods\configs\wotstat\config.json' at your own needs.

 

 

 



games0124 #163 Posted 15 December 2016 - 04:05 PM

    Private

  • Player
  • 0 battles
  • 11
  • Member since:
    11-18-2016

View PostDado_Ze, on 15 December 2016 - 05:45 AM, said:

 

There is no difference between 0.9.16 and current version in color scale or you mean with "previous" some earlier version?

Its really strange that the background shows different color then actual wn8, according the default config it should be same color...will be checked.

 

I changed the color scale in config at 0.9.16, i used the scale from wotlabs colors.xc, could be outdated....

Anyway I doubt that it could be incorrect, and would like to get suggested what should I use for default color scale in config, when possible with official links to the color scale, so I can update it regularly ...

 

I didn't pay attention to how the mod shows the colors, <value = color or >value = color...need to be checked.

 

In mean time till its updated/fixed, you can change the color scale in 'res_mods\configs\wotstat\config.json' at your own needs.

 

 

 

 

By previous version yes i mean 0.9.16 however it came as part of p0st m0ds mod pack. So maybe it was adjusted as part of the pack? I still have a backup of my old mod folder so I will find the 0.9.16 config.json copy it and replace the current one?

Dado_Ze #164 Posted 15 December 2016 - 04:23 PM

    Warrant Officer

  • Player
  • 75733 battles
  • 567
  • Member since:
    06-05-2012
Its not safe to just replace the config from 0.9.16, but you can compare that 2 configs and modify the current one...

games0124 #165 Posted 15 December 2016 - 06:27 PM

    Private

  • Player
  • 0 battles
  • 11
  • Member since:
    11-18-2016

View PostDado_Ze, on 15 December 2016 - 08:23 AM, said:

Its not safe to just replace the config from 0.9.16, but you can compare that 2 configs and modify the current one...

So I found and replaced WN8 under gradient from the old config.json. It doesn't really make any sense to me cause the numbers are all weird but it's showing the right colour now. 

Spoiler

 



Gingernut1978 #166 Posted 15 December 2016 - 09:33 PM

    Private

  • Player
  • 27343 battles
  • 6
  • Member since:
    07-11-2015

Thanks for the update.

 

One observation; when in garage and a floating battle result appears it's a bit too high, like halfway up my screen, didn't happen on previous release.



Dado_Ze #167 Posted 16 December 2016 - 12:05 AM

    Warrant Officer

  • Player
  • 75733 battles
  • 567
  • Member since:
    06-05-2012

View PostGingernut1978, on 15 December 2016 - 09:33 PM, said:

Thanks for the update.

 

One observation; when in garage and a floating battle result appears it's a bit too high, like halfway up my screen, didn't happen on previous release.

 

I'm not sure what you mean, can you make a screenshot?

Dado_Ze #168 Posted 16 December 2016 - 06:15 PM

    Warrant Officer

  • Player
  • 75733 battles
  • 567
  • Member since:
    06-05-2012

The update to 0.9.17.0.1 is not really necessary (just copy the mod from 0.917.0 to 0.9.17.0.1), I will update it anyway when I update the colors in config...

 

But first I want to be sure that's ok for default color scale.

Bellow are updated EFF, WN6, WN7 officialy xvm values from this link. WotLabs WN8, and the rest from old _Jeso_ config.

 

colors:

 

Feedback is welcome.



_Signal_ #169 Posted 17 December 2016 - 12:46 AM

    Lieutenant General

  • Player
  • 48238 battles
  • 6,631
  • [S3AL] S3AL
  • Member since:
    07-14-2011
Doesn't work for me unfortunately, missing all the png files in the session stats window.

Dado_Ze #170 Posted 17 December 2016 - 03:15 AM

    Warrant Officer

  • Player
  • 75733 battles
  • 567
  • Member since:
    06-05-2012

View Postsignal11th, on 17 December 2016 - 12:46 AM, said:

Doesn't work for me unfortunately, missing all the png files in the session stats window.

 

When you use the default config the png icons should be in 'res_mods\0.9.17.0.1\gui\maps\icons\library\YasenKrasen\' be sure you moved them from 0.9.17.0

TankSchmidt #171 Posted 17 December 2016 - 12:05 PM

    General

  • Player
  • 25262 battles
  • 9,256
  • [-GLO-] -GLO-
  • Member since:
    06-03-2011

Updated my "Da Stats" config for 0.9.17.0.1 and more importantly, also updated the colour scaling, which in case of my config is a bit more complicated. For EFF, WN6 (not displayed) and WN8 I use the same as Dado_Ze, however for WN7 (not displayed though), and winrate I use the one from here: http://wiki.wneffici...ges/Color_Scale

 

For the other stats like avg xp, frags, spots, dmg done, dmg assist, dmg received and hits rate I hope I finally managed that the mod displays the colour I want it to display :D



_Signal_ #172 Posted 17 December 2016 - 07:13 PM

    Lieutenant General

  • Player
  • 48238 battles
  • 6,631
  • [S3AL] S3AL
  • Member since:
    07-14-2011

View PostDado_Ze, on 17 December 2016 - 02:15 AM, said:

 

When you use the default config the png icons should be in 'res_mods\0.9.17.0.1\gui\maps\icons\library\YasenKrasen\' be sure you moved them from 0.9.17.0

Yeah already tried that same problem unfortunately.



Dado_Ze #173 Posted 17 December 2016 - 07:58 PM

    Warrant Officer

  • Player
  • 75733 battles
  • 567
  • Member since:
    06-05-2012

View Postsignal11th, on 17 December 2016 - 07:13 PM, said:

Yeah already tried that same problem unfortunately.

 

A screenshot would be helpful :)

_Signal_ #174 Posted 17 December 2016 - 09:14 PM

    Lieutenant General

  • Player
  • 48238 battles
  • 6,631
  • [S3AL] S3AL
  • Member since:
    07-14-2011

View PostDado_Ze, on 17 December 2016 - 06:58 PM, said:

 

A screenshot would be helpful :)

 

as requested files are in the location you specified.



Dado_Ze #175 Posted 17 December 2016 - 09:22 PM

    Warrant Officer

  • Player
  • 75733 battles
  • 567
  • Member since:
    06-05-2012

it looks like the config is broken, maybe re-download and just overwrite the config in 'World_of_Tanks\res_mods\configs\wotstat\'

 

What version you use and do you use default config?


Edited by Dado_Ze, 17 December 2016 - 09:24 PM.


avemir #176 Posted 17 December 2016 - 11:45 PM

    Private

  • Player
  • 30115 battles
  • 44
  • [2PBP] 2PBP
  • Member since:
    07-27-2011
for me works properly on 9.17.0.1

_Signal_ #177 Posted 18 December 2016 - 12:25 AM

    Lieutenant General

  • Player
  • 48238 battles
  • 6,631
  • [S3AL] S3AL
  • Member since:
    07-14-2011

View PostDado_Ze, on 17 December 2016 - 08:22 PM, said:

it looks like the config is broken, maybe re-download and just overwrite the config in 'World_of_Tanks\res_mods\configs\wotstat\'

 

What version you use and do you use default config?

 

Funny when I look in res_mods I only see 9.16 nothing else

Dado_Ze #178 Posted 18 December 2016 - 03:19 AM

    Warrant Officer

  • Player
  • 75733 battles
  • 567
  • Member since:
    06-05-2012

Well, I don't think you could run the game without updating it to 0.9.17.0.1, so you probably just missing folder 0.917.0.1 in res_mods.

Download the latest mod and take a look inside the zip file and you will understand the folder structure, everything that's inside 0.9.17.0 should be extracted inside 0.9.17.0.1



Dado_Ze #179 Posted 20 December 2016 - 05:47 PM

    Warrant Officer

  • Player
  • 75733 battles
  • 567
  • Member since:
    06-05-2012

After games0124 realized strange behavior of colors, I paid more attention to colors in config and how the mod works with values of color scale, so here the explanation...

 

In section 'palette' of config, for example the WN8 values, the colors are shown in simple way:

 

For example WN8 values between 900 and 1200 will get #77E812 (light green) color, the macro for WN8 color scale in section palette is {{c:WN8}} and its used in default config to show the background color image.

The {{c:WN8}} macro can be used to color the WN8 value to, who prefer the same colors of background image and WN8 values.

 

 

The values in section 'gradient' of config is a bit more complicated then 'palette' values.

The mod calculates gradient colors between two given colors in config.

 

For example WN8 values:

 

For WN8 value 375 we will get #F11919 (light red) color, and as example for WN8 value 455 we will get #F74C0D and that's the calculated gradient color between #F11919 and #FF8A00 on (455-375)=80 place in (550-375)=175 steps.

Here a link to online gradient generator to show how it works...

 

The macro for WN8 color scale in section gradient is {{g:WN8}} and its used in default config to show the WN8 value color.

The values of gradient section in default config are middle values of current EFF/WN6/WN7/WN8 color scale, because of gradient the middle values shows the colors in more logical way, and depends of WN8 value we will get sometimes difference between background and WN8 value color.

 

I hope I explained it simply enough :)


Edited by Dado_Ze, 19 April 2017 - 01:27 PM.


Dado_Ze #180 Posted 20 December 2016 - 07:59 PM

    Warrant Officer

  • Player
  • 75733 battles
  • 567
  • Member since:
    06-05-2012

Updated paths for 0.9.17.0.1

Corrected colors in configs

Updated custom 'green glow style' config






6 user(s) are reading this topic

0 members, 6 guests, 0 anonymous users