Jump to content


[0.9.20.1] The Relhax Modpack (OMC 2.0) with Sound/Picture/Video preview

Modpack XVM Mods Installer Preview Relhax OMC fastest 9.20.1 0.9.20.1

  • Please log in to reply
312 replies to this topic

Willster419_NA #1 Posted 11 April 2017 - 11:21 PM

    Sergeant

  • Player
  • 10 battles
  • 205
  • Member since:
    02-25-2017

Notice 1: the name "Relhax" is used as creative license. This modpack complies with the WG fair play policy

Notice 2: this an executable (exe) file, your anti virus may throw a fit because it's a new application it hasn't seen before. You need to allow/approve/add it to exceptions.

 

The Relhax Modpack

The fastest WoT modpack installer in the world. A refresh of the OMC modpack.

 

What mods are in the modpack?

https://docs.google....#gid=1719341063

 

Github page:

http://willster419.g.../RelhaxModpack/

 

Looking for the EU form post?

http://forum.worldof...icture-preview/

 

What mods are new/updated?

https://github.com/W.../commits/master

 

Have a mod request to be added?

https://docs.google....dit?usp=sharing

 

Virus total scan:

https://www.virustot...3b4d4/detection

 

Application not starting? Having Issues? Have you tried...

  • running it in compatibility mode for windows xp service pack 2 or 3?
  • running it from a command prompt?
  • right click the file, properties, unblock? 

 

Here's a video playlist on how the modpack works:

https://www.youtube....S0n4NySxXYLiIid

 

the forms won't let me embed a playlist, but here's the first video in the part of the playlist:

 

Description and reason for development

 

Modpack Features - Why would you use this modpack over Aslain's/OMC's/any other inno setup template modpack?

 

Preview Pictures:

 

Additional Information

 

Download
You can download it here: 
http://relhaxmodpack...dpack-download/
 

Credits

 

 

FAQ

 

Referenced material

 

 

This puts a whole new meaning to your quote in my form sig ScoutCub, <3 you plz don`t kick me from Relic 2ed

 

The Relhax Modpack ~ "Would you rather spend time on your mods, or your gameplay?" ~

 

Disclaimer
I am in contact with WarGaming about the modifications (mods) and their configurations (configs) to ensure that they are legal and allowed in the game. There are no "Hacks" in the relhax modpack, the name is used for artistic license.

*Please note that it does not use the classic theme as default, that is just my preference from windows. It will use the default theme.


Edited by Willster419_NA, 20 October 2017 - 05:01 AM.


LongJohn4ever #2 Posted 12 April 2017 - 04:58 PM

    Lance-corporal

  • Player
  • 39180 battles
  • 65
  • [D-H] D-H
  • Member since:
    01-16-2014

My specs:
Windows 10 Pro 64-bit
Intel® Core™ i7-5820K CPU @ 3.30GHz (12 CPUs), ~3.3GHz
Memory: 16384MB RAM
DirectX Version: DirectX 12
Card name: NVIDIA GeForce GTX 750 Ti
Dedicated Memory: 2016 MB

 

I installed and tried the mod at last sunday, i assume that nothing changed meanwhile

 

1. Attempt
I ran RelhaxModpack.exe and win defender gave virus alert, i could skip and the first window appeared with hook at Clean installation
I didn't changed anything and clicked "Install Relhax Modpack"

I made my settings but the installer windows is cutted at the bottom (watch screenshot)
I found the meanings of the buttons by trial and error
I saved my settings and then installed it

As installation was finished, i got an unhandle exeption message.
nevertheless i tried to run the game
client appeared, loading screen appeared
but screen to connect didn't appeare, just black screen

 

2. Attempt
first window appeared with hook at Clean installation
I didn't changed anything and clicked "Install Relhax Modpack"

I loaded my saved settings but the installer windows is cutted at the bottom (watch screenshot)

 

This time i disabled every mods depending to load screen!!!!!!

 

As installation was finished, i got an unhandle exeption message. (watch screenshot)
nevertheless i tried to run the game
and game worked, mods also but not everything, arti sight by Harpoon didn't work

 

RelHaxUserConfigs.xml of 2. attempt Spoiler

 

unhandle exeption message of 2. attempt Spoiler

 

RelHax-cut.jpg

RelHax-unhandle.jpg

 

 

 

 


Edited by LongJohn4ever, 12 April 2017 - 05:08 PM.


Willster419_NA #3 Posted 12 April 2017 - 05:10 PM

    Sergeant

  • Player
  • 10 battles
  • 205
  • Member since:
    02-25-2017

Could you please attach a screenshot as well of the unhandled exception?

Could you please attach your RelHaxLog.txt file so I can debug this?

 

In the sentences, "the first window appeared with hook at Clean installation", I don't understand what you mean by "hook".

 

When you say "This time i disabled every mods depending to load screen!!!!!!", I understand this as "I disabled every mod i selected just to get past the WoT loading screen.

 

EDIT: I ran the modpack with your config, and did not run into problems, I will need you to provide the RelHaxLog.txt to debug and solve this.

 

If I were to theorize I would guess it would be a problem with installing the damage log fonts.


Edited by Willster419_NA, 12 April 2017 - 05:51 PM.


Willster419_NA #4 Posted 12 April 2017 - 06:27 PM

    Sergeant

  • Player
  • 10 battles
  • 205
  • Member since:
    02-25-2017

Thank you for the extensive debug messages. I can diagnose what happened.

 

What happened is that the patching system was denied access to the folder with all the files that contain instructions on how to patch the mod configuration files. Therefore it is no surprise to me that you game failed to launch. A workaround you could try right now would be to right click the application and "run as administrator"

 

Do you have user account control enabled?

 

When the buttons are cut, was that after pressing full screen? Is your Taskbar in auto-hide mode?

 

There is not much I can do about being denied access by Windows, but I can at least handle the exception to tell the user to try running as admin.


Edited by Willster419_NA, 12 April 2017 - 06:36 PM.


LongJohn4ever #5 Posted 12 April 2017 - 07:51 PM

    Lance-corporal

  • Player
  • 39180 battles
  • 65
  • [D-H] D-H
  • Member since:
    01-16-2014

my global upload quota is depleted, download installedRelhaxFiles.log at sendspace.com

link to installedRelhaxFiles.log

 

Block Quote

 In the sentences, "the first window appeared with hook at Clean installation", I don't understand what you mean by "hook".

 i mean ticked the tick box on, at "Clean installation"

 

Block Quote

 When you say "This time i disabled every mods depending to load screen!!!!!!", I understand this as "I disabled every mod i selected just to get past the WoT loading screen.

in first attempt i enabled some loading screen mods

in second attempt i disabled these

 

Block Quote

 Do you have user account control enabled?

UAC is disabled, also i try to avoid installations, as much as possible, on the system drive

everything that's possible will be installed on another drive, game as well as RelHax folders are installed at another drive

 

Block Quote

 When the buttons are cut, was that after pressing full screen? Is your Taskbar in auto-hide mode?

 it was before and also after, yes, Taskbar is in auto-hide mode

 


Edited by LongJohn4ever, 12 April 2017 - 07:59 PM.


Willster419_NA #6 Posted 12 April 2017 - 08:01 PM

    Sergeant

  • Player
  • 10 battles
  • 205
  • Member since:
    02-25-2017

i mean ticked the tick box on, at "Clean installation"

Ok, I understand now. Yes, Clean installation is auto tick because it is a recommended setting. Same as in OMC.

 

"in first attempt i enabled some loading screen mods

in second attempt i disabled these"

Ok, i understand now. I will look into those mods and see why they cause a black screen.

 

it was before and also after, yes, Taskbar is in auto-hide mode

It looks like when the application goes to full screen it does not consider the taskbar if it is auto hide mode. I will look into it.

 

Thank you for the detailed feedback.



LongJohn4ever #7 Posted 12 April 2017 - 08:07 PM

    Lance-corporal

  • Player
  • 39180 battles
  • 65
  • [D-H] D-H
  • Member since:
    01-16-2014

View PostWillster419_NA, on 12 April 2017 - 08:01 PM, said:

"in first attempt i enabled some loading screen mods

in second attempt i disabled these"

Ok, i understand now. I will look into those mods and see why they cause a black screen.

 

sorry, i meant login mods

these two i enabled in first attempt:

Login modifications - show server ping (xvm)

Login modifications - show servers information (xvm)



Willster419_NA #8 Posted 12 April 2017 - 08:41 PM

    Sergeant

  • Player
  • 10 battles
  • 205
  • Member since:
    02-25-2017

I tried enabling auto-hide mode and i was able to replicate the situation. I can try to look into ways to fix it, but I want to know from you. Would you rather:

A. when you open the mod selection list, the taskbar autohide is disabled, and enabled when done selecting.

B. If it detects the taskbar is in autohide mode it will maximize to only the size where it won't overlap with where the taskbar could be.

I've never used my computer with autohide taskbar, so i don't know which of the two you would prefer. Whichever you like I will make it :)



LongJohn4ever #9 Posted 12 April 2017 - 09:50 PM

    Lance-corporal

  • Player
  • 39180 battles
  • 65
  • [D-H] D-H
  • Member since:
    01-16-2014

View PostWillster419_NA, on 12 April 2017 - 08:41 PM, said:

I tried enabling auto-hide mode and i was able to replicate the situation. I can try to look into ways to fix it, but I want to know from you. Would you rather:

A. when you open the mod selection list, the taskbar autohide is disabled, and enabled when done selecting.

B. If it detects the taskbar is in autohide mode it will maximize to only the size where it won't overlap with where the taskbar could be.

I've never used my computer with autohide taskbar, so i don't know which of the two you would prefer. Whichever you like I will make it :)

 

A. disable autohide

(but i tried that, i disabled autohide but nothing changed

Do you also have win10? it's really [edited]different to win7)

 

 

3. Attempt running as admin, unhandled exeption didn't appear

4. Attempt running as admin, unhandled exeption appeared again (hmmm.... now i'm not shure at all, will test it in a 5 attempt)

 

some more problems, that i forgot to mentoined:

 

every game text was in english

i removed then res_mods\0.9.17.1\text folder, then everything was fine, also hitlog and damgelog were looking better

why was that text installed?

 

Harpoons arty crosshair works only if Harpoons Arcade and Sniper crosshair is installed

This was also by omc mod

 

Request:

zoom out for Arty like this for Arcade

and a good zoom in for sniper

i don't know who makes these mods

it was the main reason for me to install omc



Willster419_NA #10 Posted 16 April 2017 - 06:23 PM

    Sergeant

  • Player
  • 10 battles
  • 205
  • Member since:
    02-25-2017

Yes, I have windows 10 and windows 7. It may not look like it though because I prefer the classic themes from the good days of Windows 98 :)

 

The game text was in english? I had assumed that all localized versions were in one language file, but that was not the case. I have fixed that. It was there in the first place because there are a few mods that modify game text, but English only.

 

I have updated the application with what I believe is a fix for your auto hide taskbar issue. Please try it and let me know if it works.

 

For all your mod requests and bugs, please use this spreadsheet so I can keep track of everything. https://docs.google....dit?usp=sharing

 

I will add the mods as soon as I can. Current priority list is:

Fix bugs with application.

Fix bugs with mods

Add new mods.



Willster419_NA #11 Posted 16 April 2017 - 06:57 PM

    Sergeant

  • Player
  • 10 battles
  • 205
  • Member since:
    02-25-2017

Just so people know (i have gotten bug reports for this)

If you are using safeshot and can't lead targets, "safe shot mod will not let you lead tanks or shoot them unless it is clear that pen will happen".

This is because you have the setting "block wasted shots" enabled. Disable it and you are good to go :)



Willster419_NA #12 Posted 17 April 2017 - 03:56 AM

    Sergeant

  • Player
  • 10 battles
  • 205
  • Member since:
    02-25-2017

Ingame rating calculation mod has been updated and fixed.

XFT's hitlog config (split only) has been fixed.

MLG mod (consumables part) has been fixed

bug of overwriting localization (forcing English text) has been fixed

 

Currently working on:

"Black Screen" bug.

Updating YasenCrasen garage stats mod

Adding dead white tanks mod



Don_van_Win_ #13 Posted 17 April 2017 - 02:23 PM

    Corporal

  • Player
  • 53063 battles
  • 199
  • [LN4ED] LN4ED
  • Member since:
    01-20-2013

Now I have the problem that I can not delete OMC. With the unins000.exe it does not work unfortunately. can you help me please?

 

Pls., write in a simple english ;-)



Willster419_NA #14 Posted 17 April 2017 - 03:22 PM

    Sergeant

  • Player
  • 10 battles
  • 205
  • Member since:
    02-25-2017
Unfortunately I can't help you with that because when I helped in OMC, I was only helping with maintaining the modpack, not writing the uninstaller. You could try using a program called iobit uninstaller. Also, Relhax mods will overwrite OMC mods so you don't have to worry about that conflict.

Willster419_NA #15 Posted 17 April 2017 - 03:28 PM

    Sergeant

  • Player
  • 10 battles
  • 205
  • Member since:
    02-25-2017

Hello everyone,

Some of you may already know, there is a bug in the modpack somewhere that is causing black screens and clients not loading. If this happens to you, please post your python.log file and your config preference file, with your RelHaxLog.txt. So far, the issue looks to be:

Bones XVM config.

However, XVM itself and the sixth sense mod are being looked at as well.

Willster419

 

Edit 1: after further investigation, it looks like it is something with the config builder tab. In theory, you should be able to install the default XVM config, or any pre built config, and you should be fine. If not, then it is a problem somewhere in the extraction of XVM. Will keep this updated

 

Edit 2: after some experimenting done and submitted to me by an anonymous user (maybe username Erstel)? I have successfully replicated the "black screen" bug. Expect a fix soon! Thank you to this user!


Edited by Willster419_NA, 18 April 2017 - 12:11 AM.


LongJohn4ever #16 Posted 17 April 2017 - 10:25 PM

    Lance-corporal

  • Player
  • 39180 battles
  • 65
  • [D-H] D-H
  • Member since:
    01-16-2014

I've tested actual files

Windows gave again alert but it had another look, not virus as last time but wind defender said it's riski to run RelhaxModpack.exe
(maybe becaus of windows update)

 

I started as Admin and didn't got unhandeled exeption

 

Bottom of the installer window and buttons are still cutted

 

Another tiny bug in your UI, when i select german lang,
then the windows size isn't shown correct, it shows only like this: `x1200


I installed also these to mods
Login modifications - show server ping (xvm)
Login modifications - show servers information (xvm)
and it worked, no black screen (seems to be fixed so far)

 

One mod makes problems, don't know if it's a xvm thing
I don't know how it is called, it's the two bars on the top, one red for enemies, the other green for allies

I don't want it, i didn't enabled it, i can't find a tick box for that
It must be a file inside "mods" folder because i changed whole res_mods folder back to my current omc mods by renaming res_mods folders
and had then this screen (screenshot attachment)

 

totalHP.jpg


i don't think that it is "totalHP"

 

but for totalHP, i didn't enable the tick box for totalHP but it seems enabled

this is from World_of_Tanks\res_mods\configs\xvm\default :

    "totalHP": {
      "enabled": true,
      "updateEvent": "PY(ON_UPDATE_HP)",
      "x": 0,
      "y": 30,
      "screenHAlign": "center",
      "align": "center",
      "shadow": {
        "distance": 1,
        "angle": 90,
        "alpha": 80,
        "blur": 5,
        "strength": 1.5
      },

 

 

link to actual installedRelhaxFiles.log

 

__________________________________________________________________________

edit, meanwhile i noticed, that you asked for RelHaxLog.txt but i gave installedRelhaxFiles.log

so here the last RelHaxLog.txt

 


Edited by LongJohn4ever, 17 April 2017 - 10:53 PM.


Willster419_NA #17 Posted 18 April 2017 - 01:06 AM

    Sergeant

  • Player
  • 10 battles
  • 205
  • Member since:
    02-25-2017

I have successfully replicated your problem! Here is what it looks like on my computer:

This is because of your windows settings. You have your title bar font set to a very high setting. If you change it down to a smaller number, the buttons will become visible, like this:

If you are ok with this as your solution, you can fix it by going to control panel, then click on display:

Then, you can adjust the size of the "Title Bars". make the font size something smaller than what you are using.

If instead, you would rather keep your title bars size, that is fine too. I will need some time to fix it.

 

As for your other question about the extra hp bars and numbers in battle, that is not an XVM setting, it is a mod called "battle observer". it is in your "mods" folder.

 

As for your tiny bug about the German language, I have fixed that, it will be released with the next update. ;)

 

EDIT:

Nevermind. I fixed your screen cutting issue. You don't have to change your title bar font size


Edited by Willster419_NA, 18 April 2017 - 01:52 AM.


Willster419_NA #18 Posted 18 April 2017 - 02:01 AM

    Sergeant

  • Player
  • 10 battles
  • 205
  • Member since:
    02-25-2017
Version 21.6.1:
- Fixed the black screen bug issue. Hooray!
- Fixed a bug where the UI would not re-enable if the user declined to confirm to uninstall
- Fixed a bug where when the German language was selected, the window size text in the mod selection window would be cut off
- Fixed a bug where if you have a large font for the title bar, the buttons in the mod selection list get cut off

Hansimean #19 Posted 18 April 2017 - 12:35 PM

    Private

  • Player
  • 31506 battles
  • 6
  • [4PDD] 4PDD
  • Member since:
    07-15-2013

Why the ad and malware?

 

http://imgur.com/a/GNa1z



Willster419_NA #20 Posted 18 April 2017 - 12:47 PM

    Sergeant

  • Player
  • 10 battles
  • 205
  • Member since:
    02-25-2017

View PostHansimean, on 18 April 2017 - 12:35 PM, said:

Why the ad and malware?

 

http://imgur.com/a/GNa1z

 

Did you read the original post?

"Notice 2: this an executable (exe) file, your anti virus may throw a fit because it's a new application it hasn't seen before. You need to allow/approve/add it to exceptions."

 

I have already done an explanation for these false positives here. I encourage you to read this post.

http://forum.worldof...6#entry10888556

 

I would be difficult to code a virus in it anyways, because I publicly post all my source code on github ;)

 

Also in your picture, it even shows it as "not-a-virus"


Edited by Willster419_NA, 18 April 2017 - 12:51 PM.






Also tagged with Modpack, XVM, Mods, Installer, Preview, Relhax, OMC, fastest, 9.20.1, 0.9.20.1

6 user(s) are reading this topic

0 members, 6 guests, 0 anonymous users