Jump to content


TANK CONTINUING TO MOVE WHEN WE DONT HAVE INTERNET ANYMORE

bug 9.16 support

  • Please log in to reply
73 replies to this topic

tuxun #1 Posted 19 August 2017 - 09:52 AM

    Staff Sergeant

  • Player
  • 21342 battles
  • 394
  • Member since:
    04-02-2013

TEST:
1)launch game. press z or w depending your keyboard layout.
2) cut internet.
3) release z or w.
4) wait 1 minute
5) connect internet


tank ran away whitout keeping receiving your keystroke but repeating the last one forever!!!

 

TEST2

1)press 100ms left key

2) press 100ms right key...

Your tank will move (100ms+random ping maybe 20ms)=120 ms at left,

then it will move (100ms+random ping maybe 30ms)=130 ms at right.

 

Do you expect your car move 3° at left when you turn from 1° at left and move from 2° at right when you turn for 1° at right?

 

Answer of support: its not a bug its expected comportement (have tanks on wrong place on server, and lag controling our tank direction)


Edited by tuxun, 19 August 2017 - 09:53 AM.


DracheimFlug #2 Posted 19 August 2017 - 09:54 AM

    Major

  • Player
  • 6130 battles
  • 2,565
  • Member since:
    11-13-2014
If you are driving your car off road over uneven terrain, then yes you most definitely expect your car not to go in a straight line unless you are forcing it to do so.

Jigabachi #3 Posted 19 August 2017 - 09:57 AM

    Field Marshal

  • Player
  • 17436 battles
  • 16,044
  • [T-D-U] T-D-U
  • Member since:
    08-12-2011
Now you only have to explain the point you are trying to make or the problem you see.

SABAOTH #4 Posted 19 August 2017 - 09:59 AM

    Captain

  • Player
  • 31735 battles
  • 2,345
  • [-133-] -133-
  • Member since:
    08-28-2011

View Posttuxun, on 19 August 2017 - 09:52 AM, said:

TEST:
1)launch game. press z or w depending your keyboard layout.
2) cut internet.
3) release z or w.
4) wait 1 minute
5) connect internet


tank ran away whitout keeping receiving your keystroke but repeating the last one forever!!!

 

TEST2

1)press 100ms left key

2) press 100ms right key...

Your tank will move (100ms+random ping maybe 20ms)=120 ms at left,

then it will move (100ms+random ping maybe 30ms)=130 ms at right.

 

Do you expect your car move 3° at left when you turn from 1° at left and move from 2° at right when you turn for 1° at right?

 

Answer of support: its not a bug its expected comportement (have tanks on wrong place on server, and lag controling our tank direction)

 

Yes, happens to me every second game.

 

Bad internet is bad for the game. Thanks for highlighting it. :medal:



jabster #5 Posted 19 August 2017 - 09:59 AM

    Field Marshal

  • Beta Tester
  • 12168 battles
  • 19,332
  • [WSAT] WSAT
  • Member since:
    12-30-2010

View Posttuxun, on 19 August 2017 - 08:52 AM, said:

TEST:
1)launch game. press z or w depending your keyboard layout.
2) cut internet.
3) release z or w.
4) wait 1 minute
5) connect internet


tank ran away whitout keeping receiving your keystroke but repeating the last one forever!!!

 

TEST2

1)press 100ms left key

2) press 100ms right key...

Your tank will move (100ms+random ping maybe 20ms)=120 ms at left,

then it will move (100ms+random ping maybe 30ms)=130 ms at right.

 

Do you expect your car move 3° at left when you turn from 1° at left and move from 2° at right when you turn for 1° at right?

 

Answer of support: its not a bug its expected comportement (have tanks on wrong place on server, and lag controling our tank direction)

 

I'd raise a ticket with support as they'll probably arrange to move the WG servers into your spare bedroom.

Edited by jabster, 19 August 2017 - 09:59 AM.


DracheimFlug #6 Posted 19 August 2017 - 10:02 AM

    Major

  • Player
  • 6130 battles
  • 2,565
  • Member since:
    11-13-2014

View Postjabster, on 19 August 2017 - 09:59 AM, said:

 

I'd raise a ticket with support as they'll probably arrange to move the WG servers into your spare bedroom.

 

If he acts quickly enough they will even build him a spare bedroom for them to move said servers into! :great:

tuxun #7 Posted 19 August 2017 - 10:04 AM

    Staff Sergeant

  • Player
  • 21342 battles
  • 394
  • Member since:
    04-02-2013

please help me to make this message more comprehensible :)

 

its also source of dancing turret bug when server dot is activated!!!

 

View PostJigabachi, on 19 August 2017 - 09:57 AM, said:

Now you only have to explain the point you are trying to make or the problem you see.

 

Well, a server not receiving tanks order should stop tanks on maps, like it was used to do before 9.16?

 

The tanks wheel continues to turn but the tanks doesnt move anymore.

 

When i press 100ms left then 100ms right i expect the tanks (at least on my client, so no ping for the moment) make 100ms left, then 100ms right, not 110ms left then maybe 120ms right with a bouncing turret ;)

 

View PostDracheimFlug, on 19 August 2017 - 09:54 AM, said:

If you are driving your car off road over uneven terrain, then yes you most definitely expect your car not to go in a straight line unless you are forcing it to do so.

 

Oh, it goes on straght line if you put it in nice line, but: when your dont press z in your car, it doesnt move, right? Or if you press z then release it, your car stop to move... unlike in wot ;)
 

View PostDracheimFlug, on 19 August 2017 - 10:02 AM, said:

 

If he acts quickly enough they will even build him a spare bedroom for them to move said servers into! :great:

 

And why would it fix the lag issue? IP Packet still would do wtf they decided too ;)
 

Edited by Jahrakajin, 19 August 2017 - 10:53 AM.


brumbarr #8 Posted 19 August 2017 - 10:14 AM

    Brigadier

  • Player
  • 35803 battles
  • 4,910
  • [GO-IN] GO-IN
  • Member since:
    07-30-2012

View PostJigabachi, on 19 August 2017 - 09:57 AM, said:

Now you only have to explain the point you are trying to make or the problem you see.

 

If you disconnect for some reason your tank keeps repeating the last input, meaning that you will drive right into the enemy team instead of being afk behind your team. So when you come bak your tank is destroyed.

tuxun #9 Posted 19 August 2017 - 10:16 AM

    Staff Sergeant

  • Player
  • 21342 battles
  • 394
  • Member since:
    04-02-2013

View Postbrumbarr, on 19 August 2017 - 10:14 AM, said:

 

If you disconnect for some reason your tank keeps repeating the last input, meaning that you will drive right into the enemy team instead of being afk behind your team. So when you come bak your tank is destroyed.

 

its not only between two disconection, its also between two ping, thats the problem (maybe the problem is just server is actually repeating last keystroke for too long without reason)

Edited by tuxun, 19 August 2017 - 10:18 AM.


Nishi_Kinuyo #10 Posted 19 August 2017 - 10:17 AM

    Major

  • Player
  • 6535 battles
  • 2,656
  • [LEWD] LEWD
  • Member since:
    05-28-2011
And it only took the OP 16k battles to find out?

qpranger #11 Posted 19 August 2017 - 10:18 AM

    Brigadier

  • Player
  • 27485 battles
  • 4,775
  • Member since:
    12-25-2013

View Posttuxun, on 19 August 2017 - 10:52 AM, said:

TEST:
1)launch game. press z or w depending your keyboard layout.
2) cut internet.
3) release z or w.
4) wait 1 minute
5) connect internet


tank ran away whitout keeping receiving your keystroke but repeating the last one forever!!!

 

TEST2

1)press 100ms left key

2) press 100ms right key...

Your tank will move (100ms+random ping maybe 20ms)=120 ms at left,

then it will move (100ms+random ping maybe 30ms)=130 ms at right.

 

Do you expect your car move 3° at left when you turn from 1° at left and move from 2° at right when you turn for 1° at right?

 

Answer of support: its not a bug its expected comportement (have tanks on wrong place on server, and lag controling our tank direction)

 

Perfect proof that the game is rigged.



tuxun #12 Posted 19 August 2017 - 10:22 AM

    Staff Sergeant

  • Player
  • 21342 battles
  • 394
  • Member since:
    04-02-2013

View PostNishi_Kinuyo, on 19 August 2017 - 10:17 AM, said:

And it only took the OP 16k battles to find out?

 

do you mean i played 16k battle since 9.16?  I don't think so :D

also: dont hope find op games here, but not for connection reason :hiding:


Edited by tuxun, 19 August 2017 - 10:24 AM.


Eaglax #13 Posted 19 August 2017 - 10:31 AM

    Lieutenant Сolonel

  • Player
  • 18076 battles
  • 3,064
  • Member since:
    01-12-2012

oh nooooo :ohmy:

the tank moves 0,02 seconds longer than it should, what shall we do???? the game is completely unplayable:ohmy:

 

Spoiler

 



Baldrickk #14 Posted 19 August 2017 - 10:35 AM

    Field Marshal

  • Player
  • 27590 battles
  • 11,490
  • [-TAH-] -TAH-
  • Member since:
    03-03-2013
I had a game where my connection dropped.

I got the full story from my platoon mates later, but my tank didn't stop.

When I reconnected, I was surrounded by dead tanks.
I had rammed two to death, and they killed off the third while it was focused on me

Browarszky #15 Posted 19 August 2017 - 10:36 AM

    Lieutenant

  • Player
  • 13366 battles
  • 1,869
  • [I-S-L] I-S-L
  • Member since:
    12-03-2013

View PostEaglax, on 19 August 2017 - 09:31 AM, said:

oh nooooo :ohmy:

the tank moves 0,02 seconds longer than it should, what shall we do???? the game is completely unplayable:ohmy:

 

Spoiler

 

 

It moves a lot longer, based on my unfortunate experiences it will move till it hits an obstacle, falls into a ravine, drowns in the river or gets destroyed by the enemy.

 

View PostBaldrickk, on 19 August 2017 - 09:35 AM, said:

 

I had a game where my connection dropped.

I got the full story from my platoon mates later, but my tank didn't stop.

When I reconnected, I was surrounded by dead tanks.
I had rammed two to death, and they killed off the third while it was focused on me

 

What a cunning plan! :amazed:


Edited by Browarszky, 19 August 2017 - 10:38 AM.


Balc0ra #16 Posted 19 August 2017 - 10:37 AM

    Field Marshal

  • Player
  • 58610 battles
  • 11,936
  • [WALL] WALL
  • Member since:
    07-10-2012

It's a server run game, even input is done via the server, not your client. Input goes from your keyboard, to the server, and back to your PC and client, thus the delay there vs your input timer. It's done that way for a reason. As then mods can manipulate as little as possible. We all know how well Ubisoft's The Division went with a full client run game. Everyone had 10 000 RPM and infinity mags, and some ran 10x faster then others. So I can take the "10ms" delay now and then.

 

And as with every sever run calculated game ever. Cutting your connection won't instantly stop everything there. When you cut your connection, the signal loops. As it takes a few before the server sees that you have disconnected or dropped out, as he pings you a few times to make sure, thus the "W" will still be pressed if you will. After trying for a few times with no results, then he will say you have DC. That and when you do, the server takes over your tank to stop it, and turn your turret over the rear hull. As a signal to the others that you have dropped out.

 

And your car comparison would be valid, if your car's input was controlled by a different system 1000 miles away. But it's not. It's done via the "client" on board the car. Thus there is no delay.



Eaglax #17 Posted 19 August 2017 - 10:42 AM

    Lieutenant Сolonel

  • Player
  • 18076 battles
  • 3,064
  • Member since:
    01-12-2012

View PostBrowarszky, on 19 August 2017 - 11:36 AM, said:

 

It moves a lot longer, based on my unfortunate experiences it will move till it hits an obstacle, falls into a ravine, drowns in the river or gets destroyed by the enemy.

 

nope, I didn't mean that.... my statement was based on his second "test", where there is no internet disconnection. So if you have a ping of 20ms your tank (apparently, I don't notice it) moves 20ms longer

 

edit: and 20ms = 0,02 seconds :)


Edited by Eaglax, 19 August 2017 - 10:53 AM.


jabster #18 Posted 19 August 2017 - 10:51 AM

    Field Marshal

  • Beta Tester
  • 12168 battles
  • 19,332
  • [WSAT] WSAT
  • Member since:
    12-30-2010

View PostBalc0ra, on 19 August 2017 - 09:37 AM, said:

 

And your car comparison would be valid, if your car's input was controlled by a different system 1000 miles away. But it's not. It's done via the "client" on board the car. Thus there is no delay.

 

Well it's similar as I often feel the car is controlled by the person sitting next to me.



Nishi_Kinuyo #19 Posted 19 August 2017 - 11:04 AM

    Major

  • Player
  • 6535 battles
  • 2,656
  • [LEWD] LEWD
  • Member since:
    05-28-2011

View Posttuxun, on 19 August 2017 - 09:22 AM, said:

View PostNishi_Kinuyo, on 19 August 2017 - 10:17 AM, said:

And it only took the OP 16k battles to find out?

 

do you mean i played 16k battle since 9.16?  I don't think so :D

also: dont hope find op games here, but not for connection reason :hiding:

Afaik, the behaviour you mentioned has been a common feature for hundreds of online games since the mid-90s (barely any online games prior to that).

You play the game; your client gets input, client sends input to server, connection is lot, server doesn't get told of input changes and continues performing according to the last input received. Internet gaming basics, really.

 

Game version has nothing to do with it.



Browarszky #20 Posted 19 August 2017 - 11:56 AM

    Lieutenant

  • Player
  • 13366 battles
  • 1,869
  • [I-S-L] I-S-L
  • Member since:
    12-03-2013

View PostEaglax, on 19 August 2017 - 09:42 AM, said:

 

nope, I didn't mean that.... my statement was based on his second "test", where there is no internet disconnection. So if you have a ping of 20ms your tank (apparently, I don't notice it) moves 20ms longer

 

edit: and 20ms = 0,02 seconds :)

 

Okay, misinterpreted, sorry.

Edited by Browarszky, 19 August 2017 - 02:06 PM.






Also tagged with bug, 9.16, support

1 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users