Jump to content


ALL of my Primo Victoria emblems DISSAPEARED


  • Please log in to reply
8 replies to this topic

TULAKfU #1 Posted 23 August 2017 - 10:16 AM

    Lance-corporal

  • Player
  • 19990 battles
  • 79
  • Member since:
    07-28-2013
What's going on? Am I the only one? I've completed the missions; the special patterns and emblems were in my garage a few days ago, but now they are gone.

jabster #2 Posted 23 August 2017 - 10:22 AM

    Field Marshal

  • Beta Tester
  • 12516 battles
  • 21,748
  • [WSAT] WSAT
  • Member since:
    12-30-2010

View PostAncientDragonSlayer, on 23 August 2017 - 09:16 AM, said:

What's going on? Am I the only one? I've completed the missions; the special patterns and emblems were in my garage a few days ago, but now they are gone.

 

Have you looked down the back of the sofa?

Igor_BL #3 Posted 23 August 2017 - 10:23 AM

    Second Lieutenant

  • Player
  • 35556 battles
  • 1,048
  • Member since:
    06-10-2015
I would like if this happened to me.

Browarszky #4 Posted 23 August 2017 - 10:33 AM

    Major

  • Player
  • 14906 battles
  • 2,790
  • [I-S-L] I-S-L
  • Member since:
    12-03-2013
Got me hopes up.. but they are still there for me. So much for free service....:mellow:

BravelyRanAway #5 Posted 23 August 2017 - 10:38 AM

    General

  • Beta Tester
  • 22194 battles
  • 8,107
  • [H_I_T] H_I_T
  • Member since:
    12-29-2010

View PostAncientDragonSlayer, on 23 August 2017 - 09:16 AM, said:

What's going on? Am I the only one? I've completed the missions; the special patterns and emblems were in my garage a few days ago, but now they are gone.

 

Inscriptions.

KLguns #6 Posted 23 August 2017 - 11:15 AM

    Captain

  • Player
  • 45929 battles
  • 2,012
  • [T-D-U] T-D-U
  • Member since:
    08-07-2012
Nothing missed, the most stupid and ugly inscriptions ever.

PowJay #7 Posted 23 August 2017 - 12:23 PM

    Colonel

  • Player
  • 33846 battles
  • 3,959
  • Member since:
    09-07-2012

I've put "HEROES" on my Hellcat, and "The Last Stand" on my Archer. I've removed all anniversary and other emblems from all of my vehicles. The problem is that you don't have chance to view them on the vehicle before they are permanently allocated. I decided that as I can't change them around to see where they look good, I won't bother with any of them.

 

As for the OP's problem. Sorry, but I've no idea unless you have actually allocated two of each already and thought they were unlimited.



laulaur #8 Posted 23 August 2017 - 12:42 PM

    Warrant Officer

  • Player
  • 46450 battles
  • 986
  • Member since:
    08-11-2011

View PostPowJay, on 23 August 2017 - 11:23 AM, said:

I've put "HEROES" on my Hellcat, and "The Last Stand" on my Archer. I've removed all anniversary and other emblems from all of my vehicles. The problem is that you don't have chance to view them on the vehicle before they are permanently allocated. I decided that as I can't change them around to see where they look good, I won't bother with any of them.

 

As for the OP's problem. Sorry, but I've no idea unless you have actually allocated two of each already and thought they were unlimited.

 

Yeah, that 'feature' is damn annoying.

I have lots of earned emblems not assigned to vehicles because you can't preview them.



Lycopersicon #9 Posted 23 August 2017 - 01:20 PM

    Lieutenant Сolonel

  • Player
  • 10537 battles
  • 3,494
  • Member since:
    07-30-2014

View PostIgor_BL, on 23 August 2017 - 11:23 AM, said:

I would like if this happened to me.

 

Put them on tanks that you are about to sell.




1 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users