Jump to content


Game crashes at start of battle - fix


  • Please log in to reply
2 replies to this topic

Nales86 #1 Posted 13 September 2017 - 10:39 PM

    Corporal

  • Player
  • 21492 battles
  • 101
  • [U-WOT] U-WOT
  • Member since:
    09-28-2014

So I had this problem where my game used to crash every now and then, sometimes several times in a row when I went from garage/queue in to battle.

Tried a ton of solutions like reinstalling windows, updating drivers, reinstalling the game, safe mode, no mods, with mods etc etc. Nothing worked, game kept crashing.

And ofcourse you can say that it might be poor laptop performance, but its a brand new MSI Leopard, so I have no problem running the game on max with around 80-100 FPS.

SSD wasnt flawed, HDD wasnt flawed, DDR was fine, CPU, GPU same story...

 

So I contacted customer support. And after some usefull copy/paste answers leading to nothing, I gave up talking to them. No need to turn grey at my age yet.

 

And then yesterday I stumbled upon a solution, which so far seems to work pretty well. Had no crashes so far, happy happy happy, joy joy joy!

 

The problem was in the REaltek HD audio driver. Appearantly more people suffered from it and after re-installing from this link , the problem hasn't occured again so far. Hope it stays this way.

The weird thing is tho, ONLY world of tanks had this problem, all other games were working just fine  :amazed:

 

Hopefully this helps some others as well, so you don't have to suffer having the experience of contacting customer support :facepalm:



Nales86 #2 Posted 14 September 2017 - 10:48 PM

    Corporal

  • Player
  • 21492 battles
  • 101
  • [U-WOT] U-WOT
  • Member since:
    09-28-2014

Screw it, problem occured again. Googled some more, checked my windows game setting, where you can turn on/off game dvr.  X-box app. That transferred me to windows game settings.

Had everything turned off, but the slider to run windows game mode was on...switched it off, hopefully that fixes the problem :facepalm:



Nales86 #3 Posted 17 September 2017 - 09:37 PM

    Corporal

  • Player
  • 21492 battles
  • 101
  • [U-WOT] U-WOT
  • Member since:
    09-28-2014

I think I finally fixed it. After all my efforts, Im now pretty confident that its not going to crash anymore :B

 

First: FU customer support, you're pretty damn useless!

 

Second, here's how I fixed it:

Since Im a carpenter and not a computer tech, I thought I updated every driver. Well, that was kinda true, I updated every driver I could think of. But not all... I stumbled on a program called driver booster. It's completely free and even managed to find a give away key, so it runs even better! (key gives you pro version, so downloads are faster and you have acces to more data)

I updated all the drivers it told me to update, some were obsolete, some outdated, most of them I didnt even knew they excist.

So after that was done, I wanted to play the game, but it crashed immediately...FML!! Turned out game got corrupted somewhere in the process, so after a fresh install I tried again. HAsnt crashed since! So now I can happily enjoy the weekend teams again, yay!

 

Anyway, if it crashes again, I will throw laptop out of the window and buy a few meter ofrope, cause its frustrating af to experience those random crashes :mellow:






1 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users