Jump to content


MOE's broken on NA for 2 months already


  • Please log in to reply
1 reply to this topic

_EXODUZ_ #1 Posted 27 October 2017 - 02:18 AM

    Lieutenant

  • Player
  • 34979 battles
  • 1,938
  • [RGT] RGT
  • Member since:
    11-05-2014

I know it doesn't really concern us, but just FYI. It happened at the end of August, 9.20 release. For example, people managed to 3 marks 907's from 88% to 95% just by playing 1 game. Others would drop 7-8% after having a crappy game in non-reward tanks (IS7, Cent. AX, etc).

Spoiler

 

Some knowledgeable players say that 9.20 has reset MOE values to default ones. You know what WG NA did? They froze 'em completely till now. I have searched NA forums, no word from WG, no statements, nada.

 

So, from one point of view, our problems are solved relatively fast. From another, it probably isn't about French labour laws, coffee breaks in the Paris office, nor the vodka loving guys in Minsk. It's the corporate structure. I worked for some multinational companies in the past, very respectable ones as well. And sometimes little problems took weeks to solve, even if it was just about calling Susan 2 floors below.

 

I dunno what to make of it. I'd be peeved as hell if it happened here on EU. I guess we shouldn't blame individuals, nor some local office, but this trend is definitely bad.



Balc0ra #2 Posted 27 October 2017 - 02:27 AM

    Field Marshal

  • Player
  • 66296 battles
  • 16,313
  • [WALL] WALL
  • Member since:
    07-10-2012

Considering NA has had the chat issue and friends list issue we had for a few days, more or less for the past few months, makes you wonder what they do their server if this is a common issue to. Not seen many complain about it tho.

 

Then again.. my last 3 MOE was more or less the same :P Went from 84 to 100% in one crappy game. Tho no one plays that tank anymore. So kinda expected.






1 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users