Jump to content


Sound settings not saved?

bug sound

  • Please log in to reply
3 replies to this topic

Vynczy #1 Posted 24 December 2017 - 10:57 PM

    Sergeant

  • Player
  • 21988 battles
  • 213
  • Member since:
    12-05-2012

Hi everyone and Merry Christmas to ya'all out there!

 

I'm having a small issue with my client, not that big of a deal but it just gets on my nerves slowly. So the thing is:

whenever I start world of tanks, the game is extremely loud, and when I check the settings, the main volume slider is on 10% - its where I left it. But it is not actually 10%, I have to move it (even by 1%) to make the sound actually on that volume level. And I have to do it every single time I start the game, even though the slider is on the position I left it the last time. It has been on for quite some time, since mid autumn maybe. 

 

Is it just me, oor..? What should I do? I thought it would be fixed with the Christmas update but it didnt. :( 



SuedKAT #2 Posted 24 December 2017 - 11:09 PM

    Lieutenant General

  • Player
  • 12154 battles
  • 6,152
  • [T-D-U] T-D-U
  • Member since:
    08-21-2014

I haven't noticed anything similar, but then again I generally leave most of the volume sliders at 100% and use my headsets volume control to set it to the level I like. 

 

The first obvious question would be if you run any mods?

 

Secondly, do this:

Pres Windows key + R.
Type %appdata%\wargaming.net
Press Enter.

 

Then move World of Tanks folder you see to your desktop, start the game and see if the same thing happens, not you will need to reapply settings such as resolution etc after this. If you still have the same issue, repeat the process above, but this time go into the World of Tanks folder, in there you'll find "preferences.xml", open that in something like Wordpad or Notepad++, then if you scroll down a bit you'll come to the volume settings, it will look like this:

 

<soundPrefs>
<detectedSpeakerConfig>2</detectedSpeakerConfig>
<masterVolume>1.000000</masterVolume>
<volume_micVivox>0.400000</volume_micVivox>
<volume_ev_gui>0.800000</volume_ev_gui>
<volume_ev_ambient>0.800000</volume_ev_ambient>
<volume_masterFadeVivox>1.000000</volume_masterFadeVivox>
<volume_ev_voice>0.800000</volume_ev_voice>
<volume_masterVivox>0.700000</volume_masterVivox>
<volume_ev_effects>0.800000</volume_ev_effects>
<volume_vehicles>0.500000</volume_vehicles>
<volume_music>0.000000</volume_music>
<volume_ev_music>0.800000</volume_ev_music>
<volume_ambient>0.500000</volume_ambient>
<volume_music_hangar>0.500000</volume_music_hangar>
<volume_voice>0.500000</volume_voice>
<volume_ev_vehicles>0.800000</volume_ev_vehicles>
<volume_gui>0.500000</volume_gui>
<volume_effects>0.500000</volume_effects>
<enable>0</enable>
<soundMode>default</soundMode>
</soundPrefs>
 

Change the volumes to what you want and save and then go in-game and see if the same thing happens.


Edited by SuedKAT, 24 December 2017 - 11:11 PM.


Vynczy #3 Posted 24 December 2017 - 11:29 PM

    Sergeant

  • Player
  • 21988 battles
  • 213
  • Member since:
    12-05-2012

View PostSuedKAT, on 24 December 2017 - 11:09 PM, said:

I haven't noticed anything similar, but then again I generally leave most of the volume sliders at 100% and use my headsets volume control to set it to the level I like. 

 

The first obvious question would be if you run any mods?

 

Secondly, do this:

Pres Windows key + R.
Type %appdata%\wargaming.net
Press Enter.

 

Then move World of Tanks folder you see to your desktop, start the game and see if the same thing happens, not you will need to reapply settings such as resolution etc after this. If you still have the same issue, repeat the process above, but this time go into the World of Tanks folder, in there you'll find "preferences.xml", open that in something like Wordpad or Notepad++, then if you scroll down a bit you'll come to the volume settings, it will look like this:

 

<soundPrefs>
<detectedSpeakerConfig>2</detectedSpeakerConfig>
<masterVolume>1.000000</masterVolume>
<volume_micVivox>0.400000</volume_micVivox>
<volume_ev_gui>0.800000</volume_ev_gui>
<volume_ev_ambient>0.800000</volume_ev_ambient>
<volume_masterFadeVivox>1.000000</volume_masterFadeVivox>
<volume_ev_voice>0.800000</volume_ev_voice>
<volume_masterVivox>0.700000</volume_masterVivox>
<volume_ev_effects>0.800000</volume_ev_effects>
<volume_vehicles>0.500000</volume_vehicles>
<volume_music>0.000000</volume_music>
<volume_ev_music>0.800000</volume_ev_music>
<volume_ambient>0.500000</volume_ambient>
<volume_music_hangar>0.500000</volume_music_hangar>
<volume_voice>0.500000</volume_voice>
<volume_ev_vehicles>0.800000</volume_ev_vehicles>
<volume_gui>0.500000</volume_gui>
<volume_effects>0.500000</volume_effects>
<enable>0</enable>
<soundMode>default</soundMode>
</soundPrefs>
 

Change the volumes to what you want and save and then go in-game and see if the same thing happens.

 

Woah, I moved the folder, started the game (thus making it create a new preferences file), then copied the SoundPref part of the new one to the old one. Now it works as intended, and all my other settings are as they used to be. :) 

Thanks for your help mate, Merry Christmas! 



SuedKAT #4 Posted 24 December 2017 - 11:30 PM

    Lieutenant General

  • Player
  • 12154 battles
  • 6,152
  • [T-D-U] T-D-U
  • Member since:
    08-21-2014

View PostVynczy, on 24 December 2017 - 11:29 PM, said:

 

Woah, I moved the folder, started the game (thus making it create a new preferences file), then copied the SoundPref part of the new one to the old one. Now it works as intended, and all my other settings are as they used to be. :) 

Thanks for your help mate, Merry Christmas! 

 

Glad to have helped, Merry Christmas right back at ya! :)





Also tagged with bug, sound

1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users