Jump to content


Google Images not working on Firefox or Chrome, but working on... Edge?

Google Images

  • Please log in to reply
5 replies to this topic

Tankyouverymuch2 #1 Posted 05 March 2018 - 09:44 PM

    Warrant Officer

  • Player
  • 29061 battles
  • 988
  • [VRTC] VRTC
  • Member since:
    09-13-2013

I seem to not be able to even click on any image that shows up on Google Images, and Firefox uses up 1/3 of my CPU power when it's on that page. Chrome has the same problem and uses the same amount of CPU but it's very slow unlike Firefox which is smooth.

 

Microsoft Edge on the other hand, CAN open the images and it doesn't use any CPU power at all... 0%.

 

Checked on Twitter #googleimages because searching on google came up with squat... and it seems others have the same issue. Restarted each browser, cleared cache, restarted PC, no cigar.

 

Does anyone have a clue what might be happening?... I've got a sneaking suspicion they might be either updating their servers, running some sort of maintenance, or they're being hacked. The 33% CPU usage is what confuses me, and it's only using that much on the Google Images site.



Nishi_Kinuyo #2 Posted 05 March 2018 - 09:59 PM

    Colonel

  • Player
  • 7266 battles
  • 3,750
  • [GUP] GUP
  • Member since:
    05-28-2011

Maybe you're browser/PC is infected?

My firefox works fine on gogol images.

<1% CPU usage, although memory might become a problem with too many tabs open.

 

I'm using Firefox Quantum 58.0.2 (64-Bit) on Windows 7, in case it might make a difference.

 

Hm... might be a bit far fetched, but DNS poisoning wouldn't be impossible either.

No wait, if it were DNS poisoning then Edge would also be causing issues... unless you'd somehow happen to use different DNS servers for different browsers.


Edited by Nishi_Kinuyo, 05 March 2018 - 10:02 PM.


Tankyouverymuch2 #3 Posted 05 March 2018 - 10:02 PM

    Warrant Officer

  • Player
  • 29061 battles
  • 988
  • [VRTC] VRTC
  • Member since:
    09-13-2013

View PostNishi_Kinuyo, on 05 March 2018 - 09:59 PM, said:

Maybe you're browser/PC is infected?

My firefox works fine on gogol images.

<1% CPU usage, although memory might become a problem with too many tabs open.

 

I'm using Firefox Quantum 58.0.2 (64-Bit) on Windows 7, in case it might make a difference.

 

I suspected it might be so I did a full PC scan, nothing came up. Windows 10 64-bit. Firefox Quantum up to date.

TsundereWaffle #4 Posted 05 March 2018 - 10:05 PM

    Field Marshal

  • Player
  • 26306 battles
  • 10,882
  • [LEWD] LEWD
  • Member since:
    03-31-2013
Hm, no issues here

Tankyouverymuch2 #5 Posted 05 March 2018 - 10:10 PM

    Warrant Officer

  • Player
  • 29061 battles
  • 988
  • [VRTC] VRTC
  • Member since:
    09-13-2013

View PostTsundereWaffle, on 05 March 2018 - 10:05 PM, said:

Hm, no issues here

 

It seems to not be affecting every user. Someone on Twitter mentioned a Javascript bug affecting more and more users. Just search with the hashtag #googleimages if you don't believe me.

Tankyouverymuch2 #6 Posted 05 March 2018 - 11:54 PM

    Warrant Officer

  • Player
  • 29061 battles
  • 988
  • [VRTC] VRTC
  • Member since:
    09-13-2013

There also are more reports on Twitter of this problem under the hashtag #GoogleDown over the last few days. I wonder what's happening...

 

Ugh... I use Twitter too much... I found this site: http://downdetector.com/status/google  Says "Google is having issues since 9:48 AM EST." March 5th.


Edited by Tankyouverymuch2, 05 March 2018 - 11:57 PM.






Also tagged with Google, Images

1 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users