Jump to content


Gun firing on it's own when leaving cap


  • Please log in to reply
7 replies to this topic

spidre #1 Posted 20 June 2018 - 05:34 PM

    Staff Sergeant

  • Player
  • 26798 battles
  • 324
  • Member since:
    10-16-2013
Just the occasional battle, my gun fires continuously when leaving the cap. I have to frantically aim for the sky to avoid hitting my team mates who are in close proximity. Anyone else have this problem?

jack_timber #2 Posted 20 June 2018 - 05:39 PM

    Lieutenant

  • Player
  • 32355 battles
  • 1,875
  • Member since:
    07-26-2014

No.

But have been hit by folks trying out their guns as they leave cap, mebbe think they are not working, no ammo loaded (done that a couple of times) or just checking LMB still works:).

Are you using any mods, tried starting in safe mode?



Homer_J #3 Posted 20 June 2018 - 05:44 PM

    Field Marshal

  • Beta Tester
  • 27652 battles
  • 29,000
  • [WJDE] WJDE
  • Member since:
    09-03-2010
Playing on a laptop?  If so then disable the trackpad while playing.

Shivva #4 Posted 20 June 2018 - 06:32 PM

    Lieutenant

  • Player
  • 29624 battles
  • 1,955
  • [J_A_G] J_A_G
  • Member since:
    05-20-2012

View Postspidre, on 20 June 2018 - 04:34 PM, said:

Just the occasional battle, my gun fires continuously when leaving the cap. I have to frantically aim for the sky to avoid hitting my team mates who are in close proximity. Anyone else have this problem?

 

One of my mates had this problem, gun would fire every time it was loaded..it stopped after a few days though. Only fix he found in the meantime for it was to unplug his USB mouse at start of a match and plug it back in a second later but same thing would happen each match.

Edited by Shivva, 20 June 2018 - 06:33 PM.


Spurtung #5 Posted 20 June 2018 - 06:58 PM

    Major General

  • Player
  • 61571 battles
  • 5,900
  • [GW-UP] GW-UP
  • Member since:
    07-05-2013
Touchpad's button stuck?

Tankyouverymuch2 #6 Posted 20 June 2018 - 09:28 PM

    Second Lieutenant

  • Player
  • 29570 battles
  • 1,220
  • [VRTC] VRTC
  • Member since:
    09-13-2013

I actually saw that happen to a guy in a T34 several years ago...

 

I don't know what causes it, but I think he managed to fix it by clicking the fire button. What I mean is, he hadn't pressed the button after the match started, and his gun kept firing, so I suggested he presses the fire button again, and it stopped.

 

Might be a glitch causing the game to think you're still holding the button down...somehow.



_b_ #7 Posted 20 June 2018 - 09:37 PM

    Colonel

  • Player
  • 54990 battles
  • 3,949
  • Member since:
    04-06-2011

Playing on laptop since day one ... after one winblows update messing up touchpad somehow it got reactivated ... and didn't notice ...and would at times fire without having pressed lmb.  Took me a while to discover the cause :teethhappy::facepalm:

 

So just verify you've actually have that disabled if on laptop :)



spidre #8 Posted 21 June 2018 - 07:55 PM

    Staff Sergeant

  • Player
  • 26798 battles
  • 324
  • Member since:
    10-16-2013

Thanks guys, it was the touchpad on my laptop. Nice to have helpful comments.

 






1 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users