Jump to content


FPS dropping to 30

fps

  • Please log in to reply
5 replies to this topic

Fizrug #1 Posted 24 November 2018 - 01:39 AM

    Lance-corporal

  • Player
  • 29161 battles
  • 90
  • Member since:
    11-29-2012

During last weeks games I got an issue: After a few games my fps drops to 30 when in 3rd person

It happens when entering a new round, my gpu goes to 100% usage and the fps drops from stable 60 to around 30.

What I found works, is to alt Tab to Snipping tool, having a snip, and then the fps returns to 60.

What is the issue?

 

System spec:

R9 270X (2gb) Power color Devil

i3-8350K @ 4.8

12gb of ram and m.2 storage


Edited by Fizrug, 24 November 2018 - 11:09 AM.


SuedKAT #2 Posted 24 November 2018 - 06:55 PM

    Lieutenant General

  • Player
  • 12154 battles
  • 7,172
  • [T-D-U] T-D-U
  • Member since:
    08-21-2014
With the info you've provided I'm 99,99% sure that you got Vsync enabled and if your FPS dips down below the refresh rate you get refresh rate / N,where N is some positive integer. For example if you have lets say an 60 Hz screen with VSync ON and you get to an intensive area and your FPS drops below 60, normally this would just go down to some random FPS, but now it goes to 30 FPS or the next set value. I'd try and either disable Vsync but if that results in some screen tearing or similar try and enable Triple Buffering, also it might be an idea to look over your settings and disable some of the more resource intensive stuff.

Fizrug #3 Posted 24 November 2018 - 10:17 PM

    Lance-corporal

  • Player
  • 29161 battles
  • 90
  • Member since:
    11-29-2012
I disabled Vsync and with 3x buffering my fps went to 120fps ish, but when gaming my fps went to 20 .. and after snipping went to 40.. and then went random high and low

Fizrug #4 Posted 24 November 2018 - 10:32 PM

    Lance-corporal

  • Player
  • 29161 battles
  • 90
  • Member since:
    11-29-2012

https://i.imgur.com/jpxRkfQ.png



SuedKAT #5 Posted 25 November 2018 - 01:28 AM

    Lieutenant General

  • Player
  • 12154 battles
  • 7,172
  • [T-D-U] T-D-U
  • Member since:
    08-21-2014
Hmm, the first thing that comes to mind are drivers and firmware, have you updated them, mostly thinking about the GPU ones, but others can make an impact as well, same with BIOS/UEFI, VBios as well as the EC controller assuming that's not included in one of the other updates. Do you happen to run the game in anything other than fullscreen? If so try and switch modes and see if there is any difference. You don't seem to have any severe cooling issues, but there are some peaks that are a little on the high side for my liking, so just to be safe I'd give the system a quick clean/blow inside, especially the fans. I'd also look at the power settings and the GPU settings, set both to best performance.

Fizrug #6 Posted 27 November 2018 - 10:09 PM

    Lance-corporal

  • Player
  • 29161 battles
  • 90
  • Member since:
    11-29-2012

Thank you for suggestions.

 

I went full screen with minimum settings and had 5+ games at 200 fps, so it seems it was something in my settings that was the issue.

 

The GPU was in the recommended update stage, and not sure if BIOS would trigger any fps drops.

 

Time to drill down what setting that makes my game not a potato looking that kills my fps


Edited by Fizrug, 28 November 2018 - 05:53 PM.






Also tagged with fps

1 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users