Jump to content


External display running on Intel GPU only - not Nvidia


  • Please log in to reply
5 replies to this topic

BacheDreyer #1 Posted 25 April 2019 - 03:39 PM

    Private

  • Player
  • 20247 battles
  • 21
  • Member since:
    06-18-2016

Ladies and gents

 

I broke my laptop display recently and thus have to use an external one. My MSI Steel Series gaming laptop now insists on running WoT on the integrated Intel GPU for the external screen, not using the Nvidia GTX 960M GPU. (There are two GPUs pre-installed, Intel's and Nvidia's.) As a result I get very low FPS and poor performance.

 

I do have selected the Nvidia graphics card as the standard for games in the Nvidia control panel, so that isn't the problem. See attached.

The problem is that the laptop refuses to let the Nvidia GPU drive the external display. Also attached. (Text in Norwegian.)

 

Any advice how I can force the external display to accept the Nvidia GPU as its main and only driver? Put differently, how do I change the external display's driver properties from "Intel integrated" to "Nvidia". There is no option to do so in the Windows 10 control panel as far as I can see.

 

Many tanks in advance for any assistance. 

Attached Files

  • Attached File   Extermal display.PNG   71.22K
  • Attached File   Nvidia control panel.PNG   65.32K


jack_timber #2 Posted 26 April 2019 - 06:56 AM

    Major

  • Player
  • 37452 battles
  • 2,852
  • Member since:
    07-26-2014

Had a laptop with similar specs and used to use an external display. I am sure I just used HDMI cable to connect and used ext monitor after using Fn + one of the Function keys to force output to monitor, so laptop mirrors display to monitor.

Didn't have to change any settings.

I could be wrong it's a long time ago....



SuedKAT #3 Posted 26 April 2019 - 05:37 PM

    Lieutenant General

  • Player
  • 12154 battles
  • 7,772
  • [T-D-U] T-D-U
  • Member since:
    08-21-2014

Plenty of stuff can be the cause for this, but the most obvious/common one would be a driver issue, what Nvidia driver are you using? Also is your Intel drivers up to date? https://www.intel.com/content/www/us/en/support/intel-driver-support-assistant.html

 

Note that the stuff most OEM suppliers show as the latest drivers on their sites and update applications tend to be quite out of date and having a MSI laptop my self I know all to well how old the stuff is that's found on the support page for my laptop.



BacheDreyer #4 Posted 26 April 2019 - 06:47 PM

    Private

  • Player
  • 20247 battles
  • 21
  • Member since:
    06-18-2016
Thanks for your responses, SuedKAT and jack_timber. All drivers are updated, and I'm using HDMI for the extra display. Still no luck. Oh, well. Will try to google about some more and try to sort it. Thanks again.

1ncompetenc3 #5 Posted 27 April 2019 - 07:09 AM

    Field Marshal

  • Player
  • 38064 battles
  • 11,994
  • Member since:
    03-18-2013
You could disable the iGPU entirely. Perhaps not an ideal solution but the screen can't use what isn't active.

jack_timber #6 Posted 27 April 2019 - 09:37 AM

    Major

  • Player
  • 37452 battles
  • 2,852
  • Member since:
    07-26-2014

Will resurrect old setup, laptop and ext display, this pm and see what I did to use Nvidia GPU rather than Intel's offering.

 






1 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users