Jump to content


Delta package bug.


  • Please log in to reply
15 replies to this topic

greek_b0y89505 #1 Posted 30 April 2019 - 07:23 PM

    Private

  • Player
  • 4009 battles
  • 5
  • [RON2] RON2
  • Member since:
    01-22-2014
Just linked my twitch account and claimed the new package, but did not get it in-game.

the_nebuchadnezzar #2 Posted 30 April 2019 - 07:36 PM

    Lieutenant

  • Player
  • 52994 battles
  • 1,607
  • [-SJA-] -SJA-
  • Member since:
    08-19-2013

View Postgreek_b0y89505, on 30 April 2019 - 06:23 PM, said:

Just linked my twitch account and claimed the new package, but did not get it in-game.

 

As the video says: log out and then log in back into WoT! 

greek_b0y89505 #3 Posted 30 April 2019 - 07:46 PM

    Private

  • Player
  • 4009 battles
  • 5
  • [RON2] RON2
  • Member since:
    01-22-2014
I`ve done that over 5 times now :)

Homer_J #4 Posted 30 April 2019 - 08:39 PM

    Field Marshal

  • Beta Tester
  • 31782 battles
  • 34,926
  • [WJDE] WJDE
  • Member since:
    09-03-2010

Give it a few mins.

 

Also, if you have the link accounts button on the Twitch Prime page then try hitting that.

 

It took about 10 mins for mine to come through but I also tried pushing that button a few more times.



greek_b0y89505 #5 Posted 30 April 2019 - 09:29 PM

    Private

  • Player
  • 4009 battles
  • 5
  • [RON2] RON2
  • Member since:
    01-22-2014

View PostHomer_J, on 30 April 2019 - 08:39 PM, said:

Give it a few mins.

 

Also, if you have the link accounts button on the Twitch Prime page then try hitting that.

 

It took about 10 mins for mine to come through but I also tried pushing that button a few more times.

 

Done that multiple times too, still did not receive the rewards. And on the page is shows as ''claimed'', like this:

_RNG #6 Posted 30 April 2019 - 10:16 PM

    Staff Sergeant

  • Player
  • 1596 battles
  • 358
  • Member since:
    02-03-2019
had never a problem with packages so far, where all here after minutes, maybe log out of twitch and wot than log in to twitch claim than log in wot

Edited by _RNG, 30 April 2019 - 10:17 PM.


SharpBlue #7 Posted 30 April 2019 - 10:24 PM

    Sergeant

  • Player
  • 61944 battles
  • 259
  • [-SJA-] -SJA-
  • Member since:
    09-03-2011

"Important: if you claim this package following the release of update 1.5, you will receive one day of World of Tanks Premium Account. If not, you will receive a standard Premium Account day."

 

So wait till the 2nd and get a better day of premium.

 

 



PayToWinDude #8 Posted 01 May 2019 - 12:25 AM

    Corporal

  • Player
  • 13665 battles
  • 131
  • Member since:
    01-03-2016
Same problem......

greek_b0y89505 #9 Posted 01 May 2019 - 12:37 AM

    Private

  • Player
  • 4009 battles
  • 5
  • [RON2] RON2
  • Member since:
    01-22-2014

View PostPayToWinDude, on 01 May 2019 - 12:25 AM, said:

Same problem......

 

I`ve listed a ticket on their website, they said i should follow these steps:

''-Double-check your Twitch prime, amazon prime and try linking the twitch account to your WG account once more

-Login into the game once more to see if you receive any popups regarding the problem. (you might need to play a battle to syng your account with the server and receive the Delta rewards.''

But still did not solve the problem, might work for you.

 



CatManuel #10 Posted 01 May 2019 - 10:18 AM

    Private

  • Player
  • 25599 battles
  • 17
  • [KOFF] KOFF
  • Member since:
    03-20-2011
Same here. No idea what s wrong.

greek_b0y89505 #11 Posted 01 May 2019 - 10:32 AM

    Private

  • Player
  • 4009 battles
  • 5
  • [RON2] RON2
  • Member since:
    01-22-2014

View PostCatManuel, on 01 May 2019 - 10:18 AM, said:

Same here. No idea what s wrong.

 

View PostPayToWinDude, on 01 May 2019 - 12:25 AM, said:

Same problem......

 

 Try the steps below:

Log out and Login again to your Twitch Account

Remove the Twitch from Wargaming Account and bind it again. (under account management)

Worked for me.


Edited by greek_b0y89505, 01 May 2019 - 10:32 AM.


ValHarris #12 Posted 01 May 2019 - 11:03 AM

    Sergeant

  • Player
  • 44307 battles
  • 201
  • [SMH] SMH
  • Member since:
    12-26-2011

View Postgreek_b0y89505, on 01 May 2019 - 10:32 AM, said:

 

 

 Try the steps below:

Log out and Login again to your Twitch Account

Remove the Twitch from Wargaming Account and bind it again. (under account management)

Worked for me.

 

That works for me too. With a final logout and login to the game.

Thank you comrade!

 

 

I love you all!


Edited by ValHarris, 01 May 2019 - 11:06 AM.


BpoHiPoBaHHbiJ #13 Posted 01 May 2019 - 11:38 AM

    Staff Sergeant

  • Player
  • 12599 battles
  • 331
  • Member since:
    07-01-2015
Works and lets you go around the bug,just unlink your WG account from Twitch,log out,log in again and link again.Go log in to game and you will get your Delta package instant.Works 100%

A_Salt_Pig #14 Posted 01 May 2019 - 12:39 PM

    Private

  • Player
  • 17596 battles
  • 36
  • Member since:
    07-17-2012

Yep, worked for me as well.

 

Thanks



Lomion_EU #15 Posted 01 May 2019 - 02:21 PM

    Warrant Officer

  • Player
  • 38924 battles
  • 623
  • [CSW] CSW
  • Member since:
    08-30-2012

View PostSharpBlue, on 30 April 2019 - 09:24 PM, said:

"Important: if you claim this package following the release of update 1.5, you will receive one day of World of Tanks Premium Account. If not, you will receive a standard Premium Account day."

 

So wait till the 2nd and get a better day of premium.

 

 

 

you know that when 1.5 released you got matched 1:1 Wot premium with WG premium time so you should have claimed it before 1.5, to get the extra WOT premium day whils retaining the extra "old" premium day.

StahlWotan #16 Posted 02 May 2019 - 12:14 AM

    Private

  • Player
  • 985 battles
  • 33
  • Member since:
    11-27-2018

View PostCatManuel, on 01 May 2019 - 10:18 AM, said:

Same here. No idea what s wrong.

 

I can tell you.

 

MADE IN RUSSIA. 






1 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users