Jump to content


"you have been disconnected from the server"


  • Please log in to reply
5 replies to this topic

TheGhostlySheep #1 Posted 27 May 2019 - 02:34 PM

    Private

  • Player
  • 6024 battles
  • 15
  • Member since:
    07-03-2016

So a few days ago i started being unable to log in. Every time I tried, I'd get an error message stating "you have been disconnected from the server". I sent WG a ticket but they are unable to help me since I'm playing on a mac and they can't help people with technical issues regarding the mac wrapper. I checked if my firewall was blocking anything but it's off. I haven't changed routers since September 2018 and it was working half a week ago so that can't be the problem.

I ran a scan of my computer using my antivirus and 2 WoT bottle files came up as corrupter, I suspect this might be the issue since it's the only thing out of the ordinary. The problem is every time i reinstall the game, or repair the game using the client, the same 2 bottle files come up as corrupted, I have no idea what's causing this or how to fix this.

Anyone got any ideas or know who I can talk to about technical issues regarding the mac version of WoT?



SiliconSidewinder #2 Posted 27 May 2019 - 03:22 PM

    Lieutenant General

  • Player
  • 29050 battles
  • 7,906
  • [WJDE] WJDE
  • Member since:
    09-16-2012

hey there try asking in the tech forum.

 

question:

did you change anything recently?

for example did you switch to the gamecenter?

or is your anti virus software new?

 

because my intiial suspicion from your description would be: the anti virus software kills your connection to protect you from WoT (since it appearently thinks it's corrupted).

 



TheGhostlySheep #3 Posted 27 May 2019 - 03:33 PM

    Private

  • Player
  • 6024 battles
  • 15
  • Member since:
    07-03-2016

View PostSiliconSidewinder, on 27 May 2019 - 03:22 PM, said:

hey there try asking in the tech forum.

 

question:

did you change anything recently?

for example did you switch to the gamecenter?

or is your anti virus software new?

 

because my intiial suspicion from your description would be: the anti virus software kills your connection to protect you from WoT (since it appearently thinks it's corrupted).

 

 

I tried changing to the gamecenter but it wouldn't download the games, just kept telling me I had no connection when I did. However, this was after I started having these issues. I was playing one day, turned my lap top off, and the next day it wouldn't log me in.

 

I've posted on the tech corner as well. See what happens, thanks.



Bordhaw #4 Posted 27 May 2019 - 09:48 PM

    Brigadier

  • Player
  • 14894 battles
  • 4,864
  • Member since:
    01-29-2017

View PostTheGhostlySheep, on 27 May 2019 - 01:34 PM, said:

So a few days ago i started being unable to log in. Every time I tried, I'd get an error message stating "you have been disconnected from the server". I sent WG a ticket but they are unable to help me since I'm playing on a mac and they can't help people with technical issues regarding the mac wrapper. I checked if my firewall was blocking anything but it's off. I haven't changed routers since September 2018 and it was working half a week ago so that can't be the problem.

I ran a scan of my computer using my antivirus and 2 WoT bottle files came up as corrupter, I suspect this might be the issue since it's the only thing out of the ordinary. The problem is every time i reinstall the game, or repair the game using the client, the same 2 bottle files come up as corrupted, I have no idea what's causing this or how to fix this.

Anyone got any ideas or know who I can talk to about technical issues regarding the mac version of WoT?

 

What bottle files?

 



TheGhostlySheep #5 Posted 27 May 2019 - 09:54 PM

    Private

  • Player
  • 6024 battles
  • 15
  • Member since:
    07-03-2016

View PostBordhaw, on 27 May 2019 - 08:48 PM, said:

 

What bottle files?

 

 

Library/Application Support/World of Tanks/Bottles/worldoftanks/drive_c/Games/World_of_Tanks/Updates/wot_1.5.0.19606_client.wgpkg.001

Library/Application Support/World of Tanks/Bottles/worldoftanks/drive_c/Games/World_of_Tanks/Updates/wot_1.5.0.19606_sdcontent.wgpkg.001

 

These are the 2 directories of the corrupted files.

 



TheGhostlySheep #6 Posted 28 May 2019 - 04:21 PM

    Private

  • Player
  • 6024 battles
  • 15
  • Member since:
    07-03-2016

Just want to give an update on the situation. This is something that I should have tried immediately but it didn't occur to me since my router hasn't changed all year. I tested whether I could connect without using my university's wifi network by using my phone's hotspot and it works fine. So I'm assuming the university has changed something with regards to the network and it's blocking WoT, since I don't own the network I doubt I can change anything so I'll just have to wait until I move out this September.

 

Thanks to everyone who tried to help, it's very much appreciated.






1 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users