Jump to content


"you have been disconnected from the server"


  • Please log in to reply
5 replies to this topic

TheGhostlySheep #1 Posted 27 May 2019 - 03:31 PM

    Private

  • Player
  • 4286 battles
  • 15
  • Member since:
    07-03-2016

So a few days ago i started being unable to log in. Every time I tried, I'd get an error message stating "you have been disconnected from the server". I sent WG a ticket but they are unable to help me since I'm playing on a mac and they can't help people with technical issues regarding the mac wrapper. I checked if my firewall was blocking anything but it's off. I haven't changed routers since September 2018 and it was working half a week ago so that can't be the problem.

I ran a scan of my computer using my antivirus and 2 WoT bottle files came up as corrupter, I suspect this might be the issue since it's the only thing out of the ordinary. The problem is every time i reinstall the game, or repair the game using the client, the same 2 bottle files come up as corrupted, I have no idea what's causing this or how to fix this.

Anyone got any ideas or know who I can talk to about technical issues regarding the mac version of WoT?



SuedKAT #2 Posted 27 May 2019 - 08:51 PM

    Lieutenant General

  • Player
  • 12154 battles
  • 7,920
  • [T-D-U] T-D-U
  • Member since:
    08-21-2014

There have been quite a few smaller patches recently so I tried to find any info about what version the Mac Wrapper was supporting but the documentation is severely lacking, both from WG's side and from Codeweavers, so the Wrapper itself might be in need of an update. However one idea that came to mind was adding cef_browser_process.exe and cef_subprocess.exe as trusted applications in you're antivirus/firewall, you'll find those two files in your install directory of WoT and they are the in-game browser of sorts that's used to display the store and similar things and since the black market event made some changes to the UI those files might be in need of updating for you and they might be blocked from doing so.

 

Other than that I'll recommend that you ask here:

https://www.codeweavers.com/compatibility/crossover/forum/world-of-tanks



TheGhostlySheep #3 Posted 27 May 2019 - 09:55 PM

    Private

  • Player
  • 4286 battles
  • 15
  • Member since:
    07-03-2016

View PostSuedKAT, on 27 May 2019 - 07:51 PM, said:

There have been quite a few smaller patches recently so I tried to find any info about what version the Mac Wrapper was supporting but the documentation is severely lacking, both from WG's side and from Codeweavers, so the Wrapper itself might be in need of an update. However one idea that came to mind was adding cef_browser_process.exe and cef_subprocess.exe as trusted applications in you're antivirus/firewall, you'll find those two files in your install directory of WoT and they are the in-game browser of sorts that's used to display the store and similar things and since the black market event made some changes to the UI those files might be in need of updating for you and they might be blocked from doing so.

 

Other than that I'll recommend that you ask here:

https://www.codeweavers.com/compatibility/crossover/forum/world-of-tanks

 

Mac doesn't use .exe files, so I'm not sure where to look for the mac equivalent of those 2 files, but I'll be sure to post on the codeweavers forum, thanks.

SuedKAT #4 Posted 27 May 2019 - 10:12 PM

    Lieutenant General

  • Player
  • 12154 battles
  • 7,920
  • [T-D-U] T-D-U
  • Member since:
    08-21-2014
Ahh right forgot one sentence to the next that it was the Mac Wrapper but they are most likely in there in some way anyhow, but yes you'll most likely get better help on the Codeweavers forums than here.

TheGhostlySheep #5 Posted 28 May 2019 - 04:22 PM

    Private

  • Player
  • 4286 battles
  • 15
  • Member since:
    07-03-2016

Just want to give an update on the situation. This is something that I should have tried immediately but it didn't occur to me since my router hasn't changed all year. I tested whether I could connect without using my university's wifi network by using my phone's hotspot and it works fine. So I'm assuming the university has changed something with regards to the network and it's blocking WoT, since I don't own the network I doubt I can change anything so I'll just have to wait until I move out this September.

 

Thanks for trying to help, it's very much appreciated.



SuedKAT #6 Posted 28 May 2019 - 09:11 PM

    Lieutenant General

  • Player
  • 12154 battles
  • 7,920
  • [T-D-U] T-D-U
  • Member since:
    08-21-2014
Many Uni networks block P2P connections, in other words torrents etc and that's the tech behind the update system of WoT so it might just have been that you needed an update that the Uni network didn't let through, so if you haven't try again and see if it works.




1 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users