Jump to content


King Tiger C


  • Please log in to reply
9 replies to this topic

Scumzor #1 Posted 09 November 2019 - 08:46 PM

    Staff Sergeant

  • Player
  • 43075 battles
  • 330
  • Member since:
    07-31-2014

Where is my King Tiger C ?

Got twitch prime since 6 months or more,clame my loots every time,also the King Tiger C form the start.

Also claimed the loots from Julliet,got everyting,but one day later tank is gone.

Every thing done in the right way as allways,i don't understand it any more.



RamRaid90 #2 Posted 09 November 2019 - 08:51 PM

    Lieutenant General

  • Player
  • 25976 battles
  • 7,108
  • [DID0] DID0
  • Member since:
    12-14-2014
The tank has vanished from everyones garage.

Pretty sure it's a bug.

Scumzor #3 Posted 09 November 2019 - 08:59 PM

    Staff Sergeant

  • Player
  • 43075 battles
  • 330
  • Member since:
    07-31-2014

View PostRamRaid90, on 09 November 2019 - 08:51 PM, said:

The tank has vanished from everyones garage.

Pretty sure it's a bug.

Well that's nice,we are paying for that and we can't do the missions,hope they wil compensate that :izmena:



DangerMouse #4 Posted 09 November 2019 - 09:04 PM

    Second Lieutenant

  • Beta Tester
  • 29353 battles
  • 1,179
  • [FLOG] FLOG
  • Member since:
    10-28-2010

View PostRamRaid90, on 09 November 2019 - 07:51 PM, said:

The tank has vanished from everyones garage.

Pretty sure it's a bug.

That's not true, its still in mine and I have played it today. Don't forget it American I thought it was gone but realised I was being an idiot and looking in German tanks. :unsure:


Edited by DangerMouse, 09 November 2019 - 09:05 PM.


Dava_117 #5 Posted 09 November 2019 - 09:06 PM

    Major General

  • Player
  • 22691 battles
  • 5,098
  • [T-D-U] T-D-U
  • Member since:
    12-17-2014
Have you removed the rental tank filter? IIRC it's considered as a rental, so if the filter is on you won't see it in garage...

Scumzor #6 Posted 09 November 2019 - 09:21 PM

    Staff Sergeant

  • Player
  • 43075 battles
  • 330
  • Member since:
    07-31-2014

View PostDava_117, on 09 November 2019 - 09:06 PM, said:

Have you removed the rental tank filter? IIRC it's considered as a rental, so if the filter is on you won't see it in garage...

Yep also did that,it just won't show,you also see at the julliet missions you can't play it cuz you don't have the tank.

 



NUKLEAR_SLUG #7 Posted 09 November 2019 - 09:21 PM

    Brigadier

  • Player
  • 34294 battles
  • 4,581
  • [FISHY] FISHY
  • Member since:
    06-13-2015

Still in mine, just player it earlier.



RamRaid90 #8 Posted 09 November 2019 - 09:40 PM

    Lieutenant General

  • Player
  • 25976 battles
  • 7,108
  • [DID0] DID0
  • Member since:
    12-14-2014

View PostDangerMouse, on 09 November 2019 - 08:04 PM, said:

That's not true, its still in mine and I have played it today. Don't forget it American I thought it was gone but realised I was being an idiot and looking in German tanks. :unsure:

 

Nope, nowhere to be seen in mine. It was the only tier VII I owned, so it's difficult to lose it. Lots of people have reported them missing.



Scumzor #9 Posted 09 November 2019 - 10:01 PM

    Staff Sergeant

  • Player
  • 43075 battles
  • 330
  • Member since:
    07-31-2014

View PostRamRaid90, on 09 November 2019 - 09:40 PM, said:

 

Nope, nowhere to be seen in mine. It was the only tier VII I owned, so it's difficult to lose it. Lots of people have reported them missing.

But where to report ? At WG or Twitch ?

who is responsable.



48jms #10 Posted 09 November 2019 - 10:14 PM

    Private

  • Player
  • 35146 battles
  • 35
  • [CR1ME] CR1ME
  • Member since:
    06-26-2017
Try to unlink and then link again twitch to your wot account. Also check in twitch settings that wot is connected. Maybe that will help.




1 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users