Jump to content


How-To: WoT on Linux


  • Please log in to reply
3 replies to this topic

Verirrter #1 Posted 22 December 2019 - 07:09 PM

    Lance-corporal

  • Player
  • 21758 battles
  • 98
  • [__TOM] __TOM
  • Member since:
    07-23-2016

Hello everyone!

With the help of several Linux users of the German WoT community I made a small Linux guide which I've already posted in the German section of this forum. Now I am trying to translate it – please forgive my bad English.

This guide has been tested on Ubuntu 18.04, 19.04 and 19.10 and with two different graphics hardware: Nvidia 1050TI and Intel Kabylake chipset (no graphics card).

 

 

 

Install Wine (https://wiki.winehq.org/Ubuntu)

 

sudo dpkg --add-architecture i386
wget -q https://dl.winehq.or...ilds/winehq.key -O- | sudo apt-key add -
sudo apt-add-repository 'deb https://dl.winehq.or...-builds/ubuntu/ eoan main'
# "eoan" only for Ubuntu 19.10; change it according to your version, e.g. "bionic" for 18.04
sudo apt update
sudo apt install --install-recommends winehq-stable

 

 

 

Install Vulkan driver (https://github.com/l...talling-drivers)

 

For Nvidia graphics cards (Ubuntu 18.04 or higher)
# Check first if your graphics card is listed: https://www.nvidia.c...px/149138/en-us, Tab "Supported products"
sudo add-apt-repository ppa:graphics-drivers/ppa

sudo dpkg --add-architecture i386
sudo apt update
sudo apt install nvidia-driver-430 libnvidia-gl-430 libnvidia-gl-430:i386
sudo apt install libvulkan1 libvulkan1:i386

 

For Intel onboard graphics
# Check first if your graphics card is listed: https://en.wikipedia...iki/Vulkan_(API)#Compatibility

sudo dpkg --add-architecture i386

sudo apt install libgl1-mesa-dri:i386

sudo apt install mesa-vulkan-drivers mesa-vulkan-drivers:i386

 

 

 

Install Lutris (https://lutris.net/downloads/)

 

sudo add-apt-repository ppa:lutris-team/lutris
sudo apt-get update
sudo apt-get install lutris
# If you want your games to be installed on a different drive, click now on "Preferences" in Lutris menu and select your folder in tab "System options".
# Alternatively enter two lines into the file "~/.config/lutris/system.yml": "system:", "  game_path: /PFAD"

 

 

 

Install WoT Game Center

 

Go to this URL using your Internet browser: https://lutris.net/g...world-of-tanks/
Select "Wine EU DXVK version" and have Lutris installing it.
If there pop-up questions about installing "Mono" and "Gecko", confirm their installation.
When Lutris has finished click on "Close". Do not click "Launch" or "Play" yet.

 

 

 

Configure WoT Game Center in Lutris

 

- Right-click on WoT icon in Lutris and select "Configure".
- At the lower left, check "Show advanced Options".
- In tab "Runner option" scroll down and activate "Windowed (virtual desktop)".
- Select the size of your screen at "Virtual desktop resolution".
- Change "Mouse Warp Override" to "Disable".
- In tab "System options" scroll down to "Switch resolution to" and select your screen size there too.
- Click on "Save".
Once again right-click on WoT icon but select "Wine configuration" this time.
- In "Wine configuration" select tab "Applications" and choose Windows version "Windows 7".
- Now switch to tab "Graphics".
- Uncheck "Automatically capture the mouse in full-screen windows".
- Uncheck "Allow the window manager to decorate the windows".
- Check "Allow the window manager to control the windows".
- Check "Emulate a virtual desktop".
- At "Desktop size" enter the size of your screen.
- If you have concerns about privacy, select tab "Drives" and disallow access to your Linux home folder by removing drive "Z:" from the list.

 

 

 

Start the Game Center and continue with the installation

 

Double-click on WoT icon in Lutris to complete Game Center's installation.
The game World of Tanks will be downloaded and installed automatically. This may take a while...
In case anything goes wrong and the Game Center does not run, right-click on WoT icon in Lutris and select "Kill all wine processes".

Recommended settings in Game Center preferences:
- Uncheck "Launch Game Center when I start the computer".
- Check "Exit Game Center when I close the main window".
- Uncheck "Minimize Game Center to the taskbar notification area when I launch the game".
- Uncheck "Automatically update installed games".
- Uncheck "Download Updates in advance".
- Check "No Uploading".

Recommended Settings in in WoT:
- Choose "Fullscreen" in Graphics settings and select the proper screen size.
- If your graphics card gets too hot when FPS exceeds 60 and and you do not like the noisy fan, select "Vertical Synchronisation".

 

 

 

Invert mouse wheel direction for zooming

 

If zooming by mouse wheel works in the wrong direction, please consider updating the Wine version in Lutris to at least 4.21. To do this, open Lutris, click the icon "Manage Versions" right next to "Wine" in left column ("Runners"). Check "lutris-4.21" in the list. Then right-click on WoT icon, choose "Configure" and select this Wine version on tab "Runner options".

 

 

 

Donate...

If you have fun playing World of Tanks under Linux, please consider donating for Lutris:
https://lutris.net/donate

 

P.S.: How do you prevent URLs in code snippets in this forum from being converted into links with "..."? That's a nasty thing.

P.P.S.: Please mail me if you've found any bugs in this description. Thanks! :-)


Edited by Verirrter, 24 December 2019 - 05:17 PM.


DoDoENT1 #2 Posted 24 December 2019 - 06:28 PM

    Private

  • Player
  • 3077 battles
  • 1
  • Member since:
    12-25-2016
Thank you for the tips. This works also on my ArchLinux, except that approximately 90% of the time loading screen never gets away. The game is loaded, the music stops, but I get stuck in the loading screen. After killing the game and entering back to it, it loads directly into the battle. However, my tank camps on its spawn point for a couple of minutes while I reload the game. Unfortunately, this is not playable. Sometimes the game stucks after returning from battle in the "refreshing the garage" screen - however, in that case, it's not that painful to restart the game.

birdstream #3 Posted 08 January 2020 - 10:26 PM

    Private

  • Player
  • 5278 battles
  • 7
  • Member since:
    11-09-2012

View PostDoDoENT1, on 24 December 2019 - 06:28 PM, said:

Thank you for the tips. This works also on my ArchLinux, except that approximately 90% of the time loading screen never gets away. The game is loaded, the music stops, but I get stuck in the loading screen. After killing the game and entering back to it, it loads directly into the battle. However, my tank camps on its spawn point for a couple of minutes while I reload the game. Unfortunately, this is not playable. Sometimes the game stucks after returning from battle in the "refreshing the garage" screen - however, in that case, it's not that painful to restart the game.

 

This is due to a vidmem allocation bug that's been plaguing this and other titles with dxvk and notably Nvidia cards. Been looking around for a 100% working solution to no avail. But doing the following seems to make the game run longer without crash: Use a lightweight DE, as GNOME, KDE and such is quite memory hungry. Make sure to have as few apps running in background (Chrome uses a lot of memory for example). Also disable transparent hugepages (it is said to make quite a loss in performance but I really couldn't say that except maybe longer loading times). To do this you can use hugeadm. In ubuntu this is provided by the hugepages package. In terminal: 

 

sudo hugeadm --thp-never

 

 



salsaheaven #4 Posted 20 January 2020 - 04:32 PM

    Private

  • Player
  • 12190 battles
  • 20
  • Member since:
    05-03-2011

View Postbirdstream, on 08 January 2020 - 09:26 PM, said:

 

This is due to a vidmem allocation bug that's been plaguing this and other titles with dxvk and notably Nvidia cards. Been looking around for a 100% working solution to no avail. But doing the following seems to make the game run longer without crash: Use a lightweight DE, as GNOME, KDE and such is quite memory hungry. Make sure to have as few apps running in background (Chrome uses a lot of memory for example). Also disable transparent hugepages (it is said to make quite a loss in performance but I really couldn't say that except maybe longer loading times). To do this you can use hugeadm. In ubuntu this is provided by the hugepages package. In terminal: 

 

sudo hugeadm --thp-never

 

 

 

Im on a RX480 but have the same problems in about 30-40% of the battles. My PC is fast enough to load into battle after restarting and start the round with the others, but I'm gonna try your fix and maybe some older DXVK Versions, too. Thanks!






1 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users