Jump to content


WoT on Server 2008 R2


This topic has been archived. This means that you cannot reply to this topic.
4 replies to this topic

marijan #1 Posted 19 March 2012 - 07:24 PM

    Private

  • Beta Tester
  • 7046 battles
  • 4
  • Member since:
    09-03-2010
I know most of you would say why you tried at all to run WoT on Server computer.
Well explanation is simple.
While working on test server in moment of pause would like to play few WoT games.
Other games like Eve Online worked perfectly fine.

System is
cpu: i7 2600
mb: Asus P8Z68 Deluxe/gen3
mem: 16GB
gc: Nvidia gtx 560
OS: Windows Server 2008 R2 Datacenter

When i try to start WoT client following error occure

“The application has failed to start because its side-by-side configuration is incorrect. Please see the application event log or use the command-line sxstrace.exe tool for more detail”

After I used sxstrace.exe tool I received this LOG

=================
Begin Activation Context Generation.
Input Parameter:
Flags = 0
ProcessorArchitecture = Wow32
CultureFallBacks = en-US;en
ManifestPath = T:\World_of_Tanks\WorldOfTanks.exe
AssemblyDirectory = T:\World_of_Tanks\
Application Config File =
-----------------
INFO: Parsing Manifest File T:\World_of_Tanks\WorldOfTanks.exe.
INFO: Manifest Definition Identity is (null).
INFO: Reference: Microsoft.VC90.CRT,processorArchitecture="x86",publicKeyToken="1fc8b3b9a1e18e3b",type="win32",version="9.0.21022.8"
INFO: Resolving reference Microsoft.VC90.CRT,processorArchitecture="x86",publicKeyToken="1fc8b3b9a1e18e3b",type="win32",version="9.0.21022.8".
INFO: Resolving reference for ProcessorArchitecture WOW64.
INFO: Resolving reference for culture Neutral.
INFO: Applying Binding Policy.
INFO: No publisher policy found.
INFO: No binding policy redirect found.
INFO: Begin assembly probing.
INFO: Did not find the assembly in WinSxS.
INFO: Attempt to probe manifest at C:\Windows\assembly\GAC_32\Microsoft.VC90.CRT\9.0.21022.8__1fc8b3b9a1e18e3b\Microsoft.VC90.CRT.DLL.
INFO: Did not find manifest for culture Neutral.
INFO: End assembly probing.
INFO: Resolving reference for ProcessorArchitecture x86.
INFO: Resolving reference for culture Neutral.
INFO: Applying Binding Policy.
INFO: No publisher policy found.
INFO: No binding policy redirect found.
INFO: Begin assembly probing.
INFO: Did not find the assembly in WinSxS.
INFO: Attempt to probe manifest at C:\Windows\assembly\GAC_32\Microsoft.VC90.CRT\9.0.21022.8__1fc8b3b9a1e18e3b\Microsoft.VC90.CRT.DLL.
INFO: Attempt to probe manifest at T:\World_of_Tanks\Microsoft.VC90.CRT.DLL.
INFO: Attempt to probe manifest at T:\World_of_Tanks\Microsoft.VC90.CRT.MANIFEST.
INFO: Attempt to probe manifest at T:\World_of_Tanks\Microsoft.VC90.CRT\Microsoft.VC90.CRT.DLL.
INFO: Attempt to probe manifest at T:\World_of_Tanks\Microsoft.VC90.CRT\Microsoft.VC90.CRT.MANIFEST.
INFO: Did not find manifest for culture Neutral.
INFO: End assembly probing.
ERROR: Cannot resolve reference Microsoft.VC90.CRT,processorArchitecture="x86",publicKeyToken="1fc8b3b9a1e18e3b",type="win32",version="9.0.21022.8".
ERROR: Activation Context generation failed.
End Activation Context Generation.

Tried to install reinstall many versions of
Microsoft Visual C++ Redistributable Package
but error stayed the same.

Thank you in advance if you can help me up with this issue.

Fum #2 Posted 19 March 2012 - 07:46 PM

    First Sergeant

  • Beta Tester
  • 9026 battles
  • 2,061
  • [FAIL] FAIL
  • Member since:
    07-15-2010
Do you have microsoft visual c++ installed?

EDIT: I just read the error before finding you wrote it below.
Since it's a server, maybe you did not reboot it after installing?

helli #3 Posted 19 March 2012 - 09:50 PM

    Sergeant

  • Player
  • 2333 battles
  • 355
  • Member since:
    02-06-2011
Version 9.0.21022.8 should be the Visual C++ 2008 Runtime, as you already posted you installed different ones did you also try that one?

marijan #4 Posted 19 March 2012 - 09:50 PM

    Private

  • Beta Tester
  • 7046 battles
  • 4
  • Member since:
    09-03-2010

View PostFum, on 19 March 2012 - 07:46 PM, said:

Do you have microsoft visual c++ installed?

EDIT: I just read the error before finding you wrote it below.
Since it's a server, maybe you did not reboot it after installing?

did restart each time after installation. but same error appear every time.

Better question is which version of
Microsoft Visual C++ Redistributable Package
to install and to work on it to try to resolve problem.

On internet I found some solutions which cannot be applied to my computer.
Version of server is WNT_6.1I_64

View Posthelli, on 19 March 2012 - 09:50 PM, said:

Version 9.0.21022.8 should be the Visual C++ 2008 Runtime, as you already posted you installed different ones did you also try that one?

I thought that I did install version 8 but it seams that it was also version 10 both time..
Will try to find version 8 and install it

UPDATE:
downloaded Microsoft Visual C++ 2008 Redistributable Package (x64)
filename: vcredist_x64.exe
filesize: 2.319kb
fileversion: 9.0.21022.8
Installed, restarted server and same error appear.
ERROR: Cannot resolve reference
Microsoft.VC90.CRT,processorArchitecture="x86",publicKeyToken="1fc8b3b9a1e18e3b",type="win32",version="9.0.21022.8"

One one web page I read info that now I have to
reinstall as well application in this case WoT.
Is that case here as well.?

marijan #5 Posted 19 March 2012 - 10:15 PM

    Private

  • Beta Tester
  • 7046 battles
  • 4
  • Member since:
    09-03-2010
UPDATE 2:
Reinstalled WOT and now it all works perfectly
Thank you all for help..

WoT is now running on Server 2008 R2 Datacenter